Ticket #5691 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

SCAYT's loader stucks under the file:// protocol

Reported by: Saare Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version: SVN (CKEditor) - OLD
Keywords: Confirmed Cc: SpellChecker.net

Description

After the autoload configuration became enabled by default in [5500], FF throws this error:

uncaught exception: Could not load cross-domain resources: scayt._base scayt.nls.caption

The culpritis is line 856 in SCAYT's loader script.
In IE, SCAYT stucks the browser for a while, and after that, an 'Uncaught Exception' error is displayed.

Change History

comment:1 Changed 4 years ago by Saare

  • Component changed from General to UI : Spell Checker

comment:2 Changed 4 years ago by SpellChecker.net

Checked out trunk again and could not reproduce the problem. May be there are some additional conditions?

comment:3 Changed 4 years ago by Saare

I'm using the replacebycode sample, IE8 and FF 3.6.3.
You probably didn't wait long enough. At the first time it took long before IE got stuck but after that it happend almost instantly. In ff, it might take a minute but eventually the error will be thrown.

comment:4 Changed 4 years ago by Saare

Firebug shows that SCAYT includes these scripts:

<script type="text/javascript" src="file://svc.spellchecker.net/spellcheck31/lf/scayt24/_base.xd.js"></script>
<script type="text/javascript" src="file://svc.spellchecker.net/spellcheck31/lf/scayt24/nls/caption.xd.js"></script>

The protocol of these scripts is file://, so the file is not available. That might be the reason why the throw statement is used at the first place.

comment:5 Changed 4 years ago by fredck

  • Keywords Confirmed added
  • Priority changed from High to Normal
  • Summary changed from SCAYT's loader stucks IE and throws error in FF to SCAYT's loader stucks under the file:// protocol

Ok, confirmed. It works on a web server, but it's not working under the file:// protocol. It's enough to open an editor sample directly from the file system.

comment:6 Changed 4 years ago by garry.yao

  • Milestone changed from CKEditor 3.3 to CKEditor 3.4

It's a matter of SCAYT's dojo loader timeout, not of priority now.

comment:7 Changed 4 years ago by SpellChecker.net

What behavior is expected:

  • SCAYT disables SCAYT button if protocol is not http[s]
  • if protocol is not http[s] SCAYT still tries to load (using http protocol) and suppress expected error messages

comment:8 Changed 4 years ago by fredck

  • Milestone changed from CKEditor 3.4 to CKEditor 3.3

For the 3.3, we must not have any error being thrown at least. Ideally, SCAYT must still work by loading from http://.

comment:9 Changed 4 years ago by SpellChecker.net

fixed on spellchecker.net side.

the behavior is: if protocol is not http[s] SCAYT still tries to load (using http protocol) and suppresses expected error messages

comment:10 Changed 4 years ago by garry.yao

  • Keywords Review- added

We still have the described issue in IE.

comment:11 Changed 4 years ago by SpellChecker.net

There were different symptoms in IE (it freezes - but later, after timeout, start working), caused by banner ad code. Now this problem fixed on spellchecker.net side.

Is there any additional info on steps to reproduce?

comment:12 Changed 4 years ago by garry.yao

  • Status changed from new to closed
  • Keywords Review- removed
  • Resolution set to fixed

It works fine now.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy