Ticket #5738 (closed Bug: invalid)

Opened 5 years ago

Last modified 3 years ago

Indent error in FCKeditor 2.6.5

Reported by: cp_raj Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.5
Keywords: Cc:

Description

Hi ,

I am getting indent error in FCKeditor 2.6.5.When ever i increase or decrease the bullets i am getting this error.Please check the screen shot for details.If fix is avaiable , help me regarding this error

Message: 'indent' is null or not an object Line: 83 Char: 3492 Code: 0 URI: file:///C:/FCKeditor_2.6.5/fckeditor/editor/js/fckeditorcode_ie.js

Attachments

indenterror.JPG (78.3 KB) - added by cp_raj 5 years ago.
RonBulletIncreaseDecrease_error.doc (28.0 KB) - added by cp_raj 5 years ago.

Change History

Changed 5 years ago by cp_raj

Changed 5 years ago by cp_raj

comment:1 Changed 5 years ago by cp_raj

please copy past the bullet list from the word document,as it is in error image. Thanks in advance

comment:2 Changed 5 years ago by cp_raj

Hi ,

Can any one reply for the above bug.so just post that , use CKeditor.already FCK is in production

comment:3 Changed 5 years ago by cp_raj

  • Priority changed from Normal to High

hi

I am getting a runtime error, while indenting the data copied from the document. Can anyone reply for this.

comment:4 Changed 4 years ago by fredck

  • Priority changed from High to Normal

WFM with the CKEditor trunk.

comment:5 Changed 4 years ago by cp_raj

WFM with the CKEditor trunk ?. I didnt get you. Can you explain me in detail.Whether you can able to reproduce the error.

comment:6 Changed 4 years ago by cp_raj

Hi,

I verfied in CKeditor.Its working good.Is it possible to get a fix in FCKeditor.Because it has been there in production.

Thanks Rajkumar CP

comment:7 Changed 4 years ago by cp_raj

Hi, Just copy from the word and click source and again click source.Its working fine.Whether there is any issue in format.

thanks

comment:8 Changed 4 years ago by cp_raj

Hi, Fix for this issue... FCKIndentCommand.prototype = {

Execute: function () {

FCKUndo.SaveUndoStep(); var A = new FCKDomRange(FCK.EditorWindow); FCK.EditorWindow.document.execCommand(this.Name); /* A.MoveToSelection(); var B=A.CreateBookmark();

var C=FCKDomTools.GetCommonParentNode(A.StartNode
A.StartContainer,A.EndNodeA.EndContainer,['ul','ol']);

if (C) this._IndentList(A,C); else this._IndentBlock(A); A.MoveToBookmark(B); A.Select();*/ FCK.Focus(); FCK.Events.FireEvent('OnSelectionChange');

},

comment:9 Changed 3 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to invalid

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy