Opened 6 years ago

Closed 6 years ago

#5801 closed Bug (fixed)

contentEditable=false on inline-elements

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3.1
Component: General Version: 3.3
Keywords: Confirmed IE Review+ Cc:

Description

#5562 is still reproducible on inline-elements.

Attachments (1)

5801.patch (902 bytes) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by garry.yao

comment:1 Changed 6 years ago by garry.yao

  • Keywords Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

The 'inline-block' style application has no known side-effects yet, as that's the way how IE present non-editable inline elements (check IE7).

comment:2 Changed 6 years ago by garry.yao

But obviously IE's non-editable support isn't perfect, check the following case where the <br /> inside a non-editable host (span) will never flow into a second paragraph, though it's out of the ticket scope.

<p> lorem ipsum <span class="test2" contentEditable="false"> Quo usque tandem abutere<br />Catilina, patientia nostra? </span> lorem ipsum </p>

comment:3 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

Ok... but it looks like using display:inline-block is not a real solution for it. For now we can declare that this is part (limitations) of the feature.

comment:4 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5567].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy