Opened 6 years ago

Closed 6 years ago

#5807 closed Bug (fixed)

Scayt causing serious problems in Firefox 2

Reported by: wwalc Owned by:
Priority: Normal Milestone: CKEditor 3.3.1
Component: UI : Spell Checker Version: 3.3
Keywords: Confirmed Firefox Cc: SpellChecker.net

Description

SCAYT is enabled by default since 3.3 and this is causing serious issues for users using an old Firefox 2. It is actually almost impossible to type text inside of CKEditor. Confirmed using FF 2.0.20 @ Win 2003.

Issue 1

Steps to reproduce

  • Open CKEditor demo: http://ckeditor.com/demo
  • Press the "New Page" button to clear all contents.
  • Click inside of editing area, start typing
  • Result: nothing happens... I cannot type anything.

Issue 2

Steps to reproduce

  • Open CKEditor demo: http://ckeditor.com/demo
  • Go to the end of article
  • Type "Thiz is a test thiz is a test", whilst typing the cursor is moved at the beginning of the first word catched by Scayt.

In the sample article we do not have any errors, but in real life using a word that is not in dictionary happens quite often and this bug becomes really painful.

Attachments (2)

5807.patch (828 bytes) - added by garry.yao 6 years ago.
5807_2.patch (573 bytes) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by fredck

  • Component changed from General to UI : Spell Checker
  • Milestone set to CKEditor 3.3.1

Let's disable SCAYT on FF2 for now.

comment:2 Changed 6 years ago by garry.yao

  • Keywords Firefox added

The first issue could be reproduced without SCAYT and is a regression of 3.3.

Changed 6 years ago by garry.yao

comment:3 Changed 6 years ago by garry.yao

  • Keywords Review? added

The patch targets the first issue, the fact is that in FF2, we simply have no 'contenteditable' support there, so the hack for blinking cursor in FF3 should not apply to it.

comment:4 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

Please leave the ticket opened after commit, because we still need to have SCAYT disabled on FF2.

Changed 6 years ago by garry.yao

comment:5 Changed 6 years ago by garry.yao

  • Keywords Review? added; Review+ removed

Issue 1 fixed with [5578].

comment:6 Changed 6 years ago by garry.yao

  • Keywords Review? removed

Fixed with [5581] confirmed by SpellChecker.net.

comment:7 Changed 6 years ago by garry.yao

Wrong version check in [5581] corrected with [5585].

comment:8 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy