Opened 5 years ago

Closed 5 years ago

#5843 closed Bug (fixed)

In CKEditor 3.3: When we set the focus in the 'instanceReady' event, FF3.6 is giving js error

Reported by: Senthil Owned by: tobiasz.cudnik
Priority: High Milestone: CKEditor 3.4
Component: General Version: 3.3
Keywords: Oracle Confirmed Review+ Cc: Senthil, Pranav

Description

When we set the editor focus in the 'instanceReady' event, we are getting the javascript error. This issue is only reproducible if the stand-alone html file(attahced:focusissue.html) is accessed from the webserver. But when i try to reproduce it from the local drive, issue was appearing intermittently. So to reproduce this issue, copy the attached sample in the webserver folder and access it in firefox 3.6 or above. Once the editor is loaded in the browser click on the 'Click me to see the issue' button once or twise. After that you will see the error(screen-shot is attached) in fire bug. After getting this error, editor area is uneditable.

Attachments (4)

FOCUSISSUE.html (3.5 KB) - added by Senthil 5 years ago.
focusIssue.png (52.7 KB) - added by Senthil 5 years ago.
5843.patch (537 bytes) - added by garry.yao 5 years ago.
5843_2.patch (529 bytes) - added by tobiasz.cudnik 5 years ago.

Download all attachments as: .zip

Change History (16)

Changed 5 years ago by Senthil

Changed 5 years ago by Senthil

comment:1 Changed 5 years ago by Senthil

For error information, you can refer the attachment "focusIssue.png"

Changed 5 years ago by garry.yao

comment:2 Changed 5 years ago by garry.yao

  • Keywords Confirmed Review? added
  • Milestone set to CKEditor 3.4
  • Owner set to garry.yao
  • Status changed from new to assigned

comment:3 Changed 5 years ago by fredck

  • Priority changed from High to Normal

comment:4 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:5 Changed 5 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5671].

comment:6 Changed 5 years ago by tobiasz.cudnik

  • Keywords Review- added; Review+ removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

This fix breaks onSelectionChange event at least on FF 3.6.

I've reverted the [5671] commit with [5692] and i'm reopening the issue.

comment:7 Changed 5 years ago by Senthil

  • Priority changed from Normal to High

Due to this patch:5843, Both in IE8/7 and Firefox3.6 many controls are not working for the second time. Ex: When we select the bold control for the selected text, it will make it as bold. Again if we highlight/select the same text and selecting the bold control it supposed to unbold the text but it is not.

Please fix it ASAP since it is breaking the basic editing functionality.

comment:8 Changed 5 years ago by tobiasz.cudnik

  • Owner changed from garry.yao to tobiasz.cudnik
  • Status changed from reopened to new

comment:9 Changed 5 years ago by tobiasz.cudnik

  • Status changed from new to assigned

Changed 5 years ago by tobiasz.cudnik

comment:10 Changed 5 years ago by tobiasz.cudnik

  • Keywords Review? added; Review- removed

After deeper checking i can say that previous patch was correct, but unfortunately contained wrong object path.

I can reproduce correct focus behavior in attached sample page using second patch.

comment:11 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:12 Changed 5 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5704].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy