Ticket #5862 (closed Bug: fixed)

Opened 5 years ago

Last modified 4 years ago

SCAYT plugin removes selection in table

Reported by: JoeK Owned by:
Priority: Normal Milestone: CKEditor 3.4.2
Component: UI : Spell Checker Version:
Keywords: Cc: damo, satya, SpellChecker.net

Description

  1. Open the Ajax sample and click on the Create Editor button.
  1. Click the Table button to insert a table.
  1. Type a word in one of the cells and double click in the word to select it.
  1. In Firefox observe 'Transferring data from svc.spellchecker.net' in the status bar. In IE observe after a few seconds 'Done' appears in the status bar. The selection is removed when the spell check has completed.

Change History

comment:1 Changed 5 years ago by fredck

  • Cc damo, satya, SpellChecker.net added; damo satya removed

It may be related to the startup delay of SCAYT, when loading its scripts.

comment:2 Changed 4 years ago by fredck

  • Milestone CKEditor 3.4 deleted

comment:3 Changed 4 years ago by SpellChecker.net

  • Keywords Confirmed added; IBM removed

comment:4 Changed 4 years ago by SpellChecker.net

  • Version changed from SVN (CKEditor) - OLD to 3.4.1 (SVN - trunk)

comment:5 Changed 4 years ago by fredck

  • Keywords Confirmed removed
  • Status changed from new to confirmed

comment:6 Changed 4 years ago by SpellChecker.net

The SpellChecker.net team has fixed this bug for the Firefox situation in the new SCAYT core, so it will be avaliable with the next SCAYT release.

We won't fix this issue in IE for now, because it's totally unclear when the described situation happens (in some cells it happens, in some not - e.g. in 3x3 table in IE8 only in two of the nine cells the described situation is observed).

comment:7 Changed 4 years ago by SpellChecker.net

  • Keywords Review? added
  • Version 3.4.1 deleted

We have updated SCAYT core on hosting. With SCAYT version 2.5.2 this bug is fixed. Please, review.

comment:8 Changed 4 years ago by garry.yao

  • Status changed from confirmed to closed
  • Keywords Review? removed
  • Resolution set to fixed
  • Milestone set to CKEditor 3.4.2

Confirmed to be fixed on both IE and FF.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy