Ticket #5866 (closed Bug: wontfix)

Opened 4 years ago

Last modified 4 years ago

IE Cursor positioning for Language:RTL style behaves differently to other browsers

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: IBM CantFix Cc: damo,joek

Description

To reproduce the defect

  1. Open Ajax Sample
  1. click on Language:RTL Style option in Styles drop down list.
  1. Type the first word and then press Space bar.

Expected Result:

See that the cursor is positioned at one space next to the end of the previous word.

Actual Result:

The Cursor moves to the beginning of the line and when we start typing the next word cursor moves to the correct position.

Change History

comment:1 Changed 4 years ago by fredck

  • Keywords CantFix added
  • Status changed from new to closed
  • Resolution set to wontfix
  • Milestone CKEditor 3.4 deleted

The reported behavior can be verified in IE only. The reason for it, much probably, is because LTR text is being written inside a RTL element. IE does it well, by moving the caret to the left, as soon as the LTR word finishes being typed.

To test it properly, you should type real RTL text and see the results. I'm sure it'll behave as expected.

Finally, this is a native browser behavior and even if we find out that it should not be like that, we would not be able to change it.

comment:2 Changed 4 years ago by garry.yao

It's just because you're typing characters (English) that have by default left-to-right layout. You'll need a Hebrew keyboard layout to test this feature.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy