Ticket #589 (closed New Feature: fixed)

Opened 7 years ago

Last modified 18 months ago

Using STYLE attribute when formatting IMG tag

Reported by: cristea@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc:

Description

I think that using STYLE attribute in IMG tag to set the distance between picture and wrapping text is better than VSPACE and HSPACE.

Is not because of the W3C recomandations but it is more practical. For example if you have a picture with ALIGN attribute set to LEFT, HSPACE will set also a margin to the left side of the picture. You can prevent this by using, for example, STYLE="margin-left:0px;margin-right:10px;" instead of HSPACE="10".

For this reason you should consider modifications to the image dialog pop-up.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=743886&group_id=75348&atid=543656

Change History

comment:1 Changed 7 years ago by martinkou

  • Reporter changed from martinkou to cristea@…

comment:2 Changed 7 years ago by martinkou

  • Type changed from Bug to New Feature

comment:3 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added

It would be a good idea to enhance the image option by adding an option to choose whether to use CSS on or not.

comment:4 Changed 6 years ago by philwo

I think this is a rather important ticket, as setting the hspace / vspace of images won't work, because they get overridden by CSS (for example, my CSS framework has

  • { margin: 0; padding: 0;

}

somewhere in the basic stylesheets, and thus I can't set a hspace / vspace using FCKeditor on my images ...

comment:5 Changed 5 years ago by mattalexx

I'm having trouble with this too. When is it planned to be implemented?

comment:6 Changed 18 months ago by alfonsoml

  • Status changed from confirmed to closed
  • Resolution set to fixed

This is the way that it works now in CKEditor

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy