Ticket #5901 (closed Bug: invalid)

Opened 4 years ago

Last modified 21 months ago

Firefox 3.6.4 Breaking background-image:url('foo/bar.png'); with "

Reported by: wolfehr Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version: 3.3.1
Keywords: Firefox Cc:

Description

Tested on Firefox 3.6.4 - CKEditor Version 3.3.1

Code = <div id="right_top" style="width: 308px; height: 13px; background-image: url('/images/right_top.png');">Test</div>

This is converted after switching source view off and on again to the following:

Amended = <div id="right_top" style="width: 308px; height: 13px; background-image: url(&quot;/images/right_top.png&quot;);">

Test</div>

If this is then submitted, the html is completely garbled by the editor and becomes the folloing:

Final output = <div id="right_top" images="" right_top.png="" style="width: 308px; height: 13px;">

Test</div>

Inline styling has been fine up until now and this has only happened since this new version of firefox.

Change History

comment:1 Changed 4 years ago by tobiasz.cudnik

  • Priority changed from High to Normal
  • Keywords Firefox Confirmed added; &quot;, firefox 3.6.4 quote problem, firefox garbling background-image removed

I can confirm it on FF 3.6.3 also. This is not CKEditor regression.

comment:2 Changed 4 years ago by fredck

  • Keywords Pending added; Confirmed removed
  • Component changed from General to Core : Output Data

There are some things to be considered:

  • It looks like Firefox transforms the single quote char (') into a quote char (") when parsing the HTML. So, that's what the editor gets from it.
  • It *should* be ok to have &quot; there. It *should* not break things, other than being the right way to have quote chars inside elements' attributes.
  • The data you see in the source view is *exactly* the same you get from the editor output. In fact we have the same procedure being used for both cases. So, it's impossible to have a different output.

Regarding the last point, I think there is something else handling the data. I'm not able to reproduce the problem in any way.

Can you investigate it a bit further, giving us more details on how to reproduce the problem? A sample page could help a lot.

comment:3 Changed 4 years ago by wolfehr

I believe this issue is to do with implementation where mysql_real_escape_string is being used on the content. This is what is going through when submitting the above:

Data Submitted Through Editor - <div id="right_top" style="width: 308px; height: 13px; background-image: url(&quot;/images/right_top.png&quot;);">Test</div>

After processing WITH mysql_real_escape_string - <div id="\&quot;right_top\&quot;" style="" 308px;="" height:="" 13px;="" background-image:="" url(&quot;="" images="" right_top.png&quot;);\="">Test</div> </div>

After processing WITHOUT mysql_real_escape_string - <div id="right_top" style="width: 308px; height: 13px; background-image: url(&quot;/images/right_top.png&quot;);">Test</div>

comment:4 Changed 21 months ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to invalid

Sorry but this is not CKEditor issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy