Opened 6 years ago

Closed 6 years ago

#6083 closed Bug (fixed)

IE: Selection collapses when inserting special char

Reported by: fredck Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.2.2
Keywords: Cc:

Description

  1. Clear the cache and load the editor.
  2. Select any work by double click.
  3. Click the "Insert Special Character" button.
  4. Click on any character.

Note that the char has been added at the start of the selection, instead of replacing it.

Attachments (3)

6083.patch (1.2 KB) - added by tobiasz.cudnik 6 years ago.
6083_2.patch (2.6 KB) - added by garry.yao 6 years ago.
6083_3.patch (684 bytes) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by fredck

  • Status changed from new to confirmed
  • Version set to 3.2.2

Confirmed with version 3.2.2. Ok with the 3.2.1.

comment:2 Changed 6 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from confirmed to assigned

Changed 6 years ago by tobiasz.cudnik

comment:3 Changed 6 years ago by tobiasz.cudnik

  • Status changed from assigned to review

Adding selection lock when opening a dialog and changing order of instruction a bit in specialchars dialog seems to resolve the issue.

comment:4 Changed 6 years ago by garry.yao

  • Status changed from review to review_failed

Same issue applies to other dialogs including form fields, the problem is that selection range is not correctly figured out at the first time.

Changed 6 years ago by garry.yao

comment:5 Changed 6 years ago by garry.yao

It turns out that the selection restoring logic, might normalize the text nodes thus potentially invalidate the locked selection's correctness, proposing here an isolated approach between these two.

comment:6 Changed 6 years ago by tobiasz.cudnik

I understand that 6083_2.patch patch is targeted to review ?

comment:7 Changed 6 years ago by garry.yao

This's a fundamental change, give it your review pls, and we need a 3rd involved in.

comment:8 follow-up: Changed 6 years ago by tobiasz.cudnik

Removing focus from onInsertHtml and onInsertElement will break #6358 again in webkit.

Changed 6 years ago by garry.yao

comment:9 in reply to: ↑ 8 Changed 6 years ago by garry.yao

  • Owner changed from tobiasz.cudnik to garry.yao
  • Status changed from review_failed to review

Replying to tobiasz.cudnik:

Removing focus from onInsertHtml and onInsertElement will break #6358 again in webkit.

I don't get #6358 broken after the patch, but anyway the previous patch's impact could be even reduced, propose the new one here.

comment:10 Changed 6 years ago by Saare

  • Status changed from review to review_passed

comment:11 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [5962].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy