Opened 6 years ago

Closed 6 years ago

#6133 closed Bug (fixed)

Styled paragraphs result on buggy list creation

Reported by: fredck Owned by: mani
Priority: Normal Milestone: CKEditor 3.4.2
Component: Core : Lists Version: 3.4.1
Keywords: Firefox Cc: satya_minnekanti@…

Description

  1. Clear the editor.
  2. Type two paragraphs.
  3. CTRL+A to select all.
  4. Hit the "Bold" button.
  5. Hit the "Unordered List" button.

Note that there is a line space between the items. This is what we have on source:

<ul>
	<li>
		<strong>Para 1</strong><br />
		&nbsp;</li>
	<li>
		<strong>Para 2</strong><br />
		&nbsp;</li>
</ul>

We should not have the "<br />&nbsp;" thing on each item.

This doesn't happen if the paragraphs are not styled.

Attachments (2)

#6133.patch (484 bytes) - added by mani 6 years ago.
Patch
6133_2.patch (432 bytes) - added by mani 6 years ago.
Patch

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by Saare

  • Keywords Firefox added
  • Status changed from new to confirmed

Only happens on FF.

comment:2 Changed 6 years ago by mani

  • Owner set to mani
  • Status changed from confirmed to assigned

Changed 6 years ago by mani

Patch

comment:3 Changed 6 years ago by mani

  • Status changed from assigned to review

comment:4 Changed 6 years ago by Saare

#6267 is a DUP.

comment:5 Changed 6 years ago by satya

  • Cc satya_minnekanti@… added

comment:6 Changed 6 years ago by tobiasz.cudnik

  • Status changed from review to review_failed

I'm not sure we should remove fix from #3409. have you checked that it's not more reproducible ?

Changed 6 years ago by mani

Patch

comment:7 Changed 6 years ago by mani

  • Status changed from review_failed to review

6133_2 remove lines add in 3409 because #2886 fix all issue consists with "line height" by add '&nbsp' sign. So at this moment #3409 is completly unnecessary

comment:8 Changed 6 years ago by tobiasz.cudnik

  • Status changed from review to review_passed

comment:9 Changed 6 years ago by fredck

  • Milestone changed from CKEditor 3.5 to CKEditor 3.4.2

comment:10 Changed 6 years ago by mani

  • Resolution set to fixed
  • Status changed from review_passed to closed

fixed with revision [5922]

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy