Ticket #6138 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

List indentation is not working

Reported by: fredck Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.4.1
Component: Core : Lists Version: 3.3.2
Keywords: IBM Cc: damian.chojna@…

Description

  1. Load this HTML:
<ul>
	<li>Line 1</li>
	<li>Line 2</li>
</ul>
  1. CTRL+A to select all.
  2. Click the "Decrease Indentation" button.

The list will not be removed, and the items contents will be now inside <p> elements.

We have the same issue when using "Increase Indentation" on step 3, having the indentation being applied to the new <p> instead of the <ul>.

Attachments

6138.patch (920 bytes) - added by tobiasz.cudnik 4 years ago.
6138_2.patch (881 bytes) - added by tobiasz.cudnik 4 years ago.

Change History

comment:1 Changed 4 years ago by tobiasz.cudnik

  • Status changed from new to assigned
  • Owner set to tobiasz.cudnik

Changed 4 years ago by tobiasz.cudnik

comment:2 follow-up: ↓ 4 Changed 4 years ago by fredck

It's R+ for me, but it looks like you forgot putting it on review.

Be sure to open a ticket for Firebug before committing, as we should not have such "_firebugConsole" checks in the code.

comment:3 Changed 4 years ago by damo

  • Keywords IBM added
  • Cc damian.chojna@… added

comment:4 in reply to: ↑ 2 Changed 4 years ago by Saare

Replying to fredck:

Be sure to open a ticket for Firebug before committing, as we should not have such "_firebugConsole" checks in the code.

The issue was already reported by Garry as issue 2960 and has been fixed in Firebug 1.6a9.

Changed 4 years ago by tobiasz.cudnik

comment:5 Changed 4 years ago by tobiasz.cudnik

  • Status changed from assigned to review

Indeed i forgot to put it on a review, sorry. I've removed Firebug related code in second patch and updated bookmarks to new prefix (cke).

comment:6 Changed 4 years ago by Saare

  • Status changed from review to review_passed

comment:7 Changed 4 years ago by Saare

  • Status changed from review_passed to review_failed

I can still reproduce the bug in FF.

comment:8 Changed 4 years ago by tobiasz.cudnik

  • Status changed from review_failed to review

You need to disable firebug prior to version 1.6 to have it working.

comment:9 Changed 4 years ago by Saare

  • Status changed from review to review_passed

comment:10 Changed 4 years ago by tobiasz.cudnik

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [5842].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy