Ticket #621 (closed New Feature: fixed)

Opened 7 years ago

Last modified 13 months ago

RC3: IE and Gecko generate different HTML code

Reported by: agrebnev@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: fredck

Description

Hello

I use diff (merge) algorithm on html generated by FCKEditor.

But there is a problem, under IE and Gecko browsers FCKEditor generate different HTML code for equals texts. For example:

IE: <div style="MARGIN-TOP: 10px" align="justify"> Gecko: <div align="justify" style="margin-top: 10px;" >

Of course diff algorithm considers these line as different.

It will be very cool to force browsers to generate equals HTML code.

Thanks


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1162811&group_id=75348&atid=543656

Change History

comment:1 Changed 7 years ago by martinkou

  • Cc fredck added
  • Reporter changed from martinkou to agrebnev@…

This is quite difficult, because the HTML is generated and managed by the browser, not the editor.

In any case, the final behavior is the same (the attributes order and contents case doesn't change the result). So, I'll set your request as a "Feature Request". Let's see what could be done in the future.

Best regards, FredCK


Moved from SF. Original poster: fredck

comment:2 Changed 7 years ago by w.olchawa

  • Keywords Confirmed added

comment:3 Changed 13 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

This was fixed a long time ago. Attributes are sorted and style lowercased.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy