Opened 9 years ago

Closed 9 years ago

#624 closed New Feature (duplicate)

Opera browser

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: saul11@…, alfonsoml, molumen@…, mase_15@…, simo@…


Could you do sth, cause Opera doesn`t start FCKE...

Moved from SF:

Change History (2)

comment:1 Changed 9 years ago by martinkou

  • Cc saul11@… alfonsoml molumen@… mase_15@… simo@… added
  • Reporter changed from martinkou to anonymous

Opera compatibility effort:

Moved from SF. Original poster: saul11

these bugs have been marked as duplicate of this one:

You can test the current support for Opera in the nightly builds, some bugs are still present so it can't be enabled for general use.

Moved from SF. Original poster: alfonsoml

I just tested FCKeditor with Opera 9, weekly build 8321 Display was fine, only editing showed some problems:

  • Text-formatting (bold, italic etc.) can be applied, but

can't be removed (the corresponding button is not highlighted as 'pressed').

  • Saving does not work
  • Table dialogue doesn't work (but display of tables is


Please work on the Opera support. I think at least the basic features (simple text formatting etc.) could be realized in Opera. And as Opera 9 is still in pre-beta state, there's also a chance to ask the Opera-devs for new functions or get misbehaviours fixed until the final release.

Moved from SF. Original poster: Anonymous

Opera 9 have "editor mode" and supports all this stuff. I tested Opera 9 with SPAW editor, and it works fine (for beta state of course)

Moved from SF. Original poster: Anonymous

Ok People, For those who don't know, the reason why FCKE doesn't, can't and won't have support for opera in the forseeable future is because FCK relies on the browser being able to do certain things. I.E has MSHTML, Gecko (Firefox et al) have Midas, and Safari is implementing something too. Opera does not have this! No matter how good opera is as a browser, FCK can't use it until it has these features. If you would like to have FCK support you need to talk to Opera first. Once support is added at their end, the developers can then try and support opera this end.

Moved from SF. Original poster: Anonymous

Any comments about Opera? Somebody? Please!

Moved from SF. Original poster: molumen

Well it's very sad that Opera isn't supported... It is a good browser and enough popular to be interesting to FCKE devellopers. Are there any plans to support this browser someday?

Moved from SF. Original poster: molumen

does opera have content editability like I.E and FireFox/Mozilla do?

Moved from SF. Original poster: mase_15

I think Opera is not a supported platform :-)

Moved from SF. Original poster: simo

comment:2 Changed 9 years ago by alfonsoml

  • Resolution set to duplicate
  • Status changed from new to closed

dup of #1301

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy