Opened 5 years ago

Closed 3 years ago

#6308 closed Bug (fixed)

"vertical" resize_dir still sets width CSS

Reported by: LloydSkoyd Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: UI : Toolbar Version: 3.4
Keywords: Cc: mcianc@…

Description (last modified by krst)

When resize_dir is configured to be "vertical", only vertical size changes should be allowed. However, after some vertical resizing, a width CSS style (in px) is set on the editor span. For example:

style="width:1019px"

This is a problem if the editor is supposed to be 100% wide. The editor is now stuck at being the same width, even when the window/container resizes.

The same issue probably applies to "horizontal" resize_dir, but with a height CSS style.

Both issues can be fixed by changing the editor resize function call in resize/plugin.js line43 to:

  editor.resize( resizeHorizontal ? width : null, resizeVertical ? height : null );

This will cause the width/height to only be changed when necessary.

Attachments (1)

6308.patch (589 bytes) - added by garry.yao 3 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by krst

  • Description modified (diff)
  • Keywords HasPatch added; resize removed
  • Status changed from new to confirmed

Confirmed. After applying provided change, editor resizes itself depending on window size

comment:2 Changed 5 years ago by mcianc

  • Cc mcianc@… added

comment:3 follow-up: Changed 5 years ago by krst

linked with #6565

comment:4 in reply to: ↑ 3 Changed 5 years ago by krst

Replying to krst:

linked with #6565

I linked this with wrong issue, it should be #6365

comment:5 Changed 4 years ago by fbingha

The suggested fix works, let's get this in.

Changed 3 years ago by garry.yao

comment:7 Changed 3 years ago by garry.yao

  • Component changed from General to UI : Toolbar
  • Keywords HasPatch removed
  • Owner set to garry.yao
  • Status changed from confirmed to review

We dont need to fix the horizontal-only resize since percentage val is not supported for editor height.

comment:8 Changed 3 years ago by fredck

  • Milestone set to CKEditor 3.6.3
  • Status changed from review to review_passed

Please fix the coding style when committing.

comment:9 Changed 3 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [7386].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy