Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#6330 closed Bug (fixed)

Roman list style are not pasted properly from Word

Reported by: wwalc Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.4.3
Component: Plugin : Paste from Word Version: 3.1
Keywords: IBM Cc:

Description (last modified by wwalc)

When pasting from Word, lists like:

i. foo
ii. bar

become

a. foo
b. bar

It is wrong, list style type should be preserved.

Reproduced in 3.4, worked fine in 3.0. I could not reproduce it in other versions due to #5399.

Confirmed on: Win 7 Professional N 64-bit EN + Office 2010 standard (en_office_standard_2010_x64_515548.exe)

Attachments (3)

ckeditor_pasting_bullets.png (22.2 KB) - added by wwalc 6 years ago.
bullets.doc (23.5 KB) - added by wwalc 6 years ago.
6330.patch (1.3 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (16)

Changed 6 years ago by wwalc

Changed 6 years ago by wwalc

comment:1 Changed 6 years ago by wwalc

  • Status changed from new to confirmed

comment:2 Changed 6 years ago by wwalc

  • Component changed from General to Core : Pasting

comment:3 Changed 6 years ago by wwalc

  • Description modified (diff)

comment:4 Changed 6 years ago by garry.yao

  • Milestone set to CKEditor 3.5
  • Owner set to garry.yao
  • Status changed from confirmed to review
  • Summary changed from Ordered lists are not pasted properly from Word to Roman list style are not pasted properly from Word

Changed 6 years ago by garry.yao

comment:5 Changed 6 years ago by garry.yao

  • Keywords IBM added

comment:6 Changed 6 years ago by fredck

  • Milestone changed from CKEditor 3.5 to CKeditor 3.4.3

comment:7 Changed 6 years ago by fredck

  • Keywords IE added

comment:8 Changed 6 years ago by fredck

  • Status changed from review to review_failed

It works well for me with Firefox, even before the patch.

In IE, I'm always having the following output, even after patch (it makes no difference):

1. asasd 
  1. aasdsd 
  2. asd
2. asd 
  1. asd 
  2. asd 
    1. asdasd 
    2. asd 
      1. asdasd 
        1. asdasd
  3. asd

I'm using the document attached by wwalc for testing.

comment:9 Changed 6 years ago by garry.yao

  • Status changed from review_failed to review
  1. Firefox illustration you see is a recent Firefox regression see #6662;
  2. For the patch to work need pasteFromWordRemoveStyles turned off, as list-style-type is actually a style.

comment:10 Changed 6 years ago by garry.yao

  • Keywords IE removed

comment:11 Changed 6 years ago by fredck

  • Status changed from review to review_passed

I'm accepting the patch because it has nothing to do with it, but I think we have something to rethink in the future. We, developers, know that list-style-type is related to styles, but I'm not sure that's the way end users understand it, so it should not depend on pasteFromWordRemoveStyles much probably.

comment:12 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6115], the issue mentioned by Fred will be tackled at #6635.

comment:13 Changed 3 years ago by fredck

  • Component changed from Core : Pasting to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy