Opened 6 years ago

Closed 6 years ago

#6341 closed Bug (fixed)

Mouse cursor on the editor area does not change to "insert icon".

Reported by: Senthil Owned by: Saare
Priority: Normal Milestone: CKEditor 3.4.2
Component: General Version: 3.3.1
Keywords: Oracle Cc: Senthil

Description

when the mouse cursor hovers over the editor area the "pointer" icon does not change to the "insertion" icon. This behaviour is confsuing our customers and they think that the editor area is not accessible. Also we have noticed, FCKEditor 2.6.6 works fine for the same usecase.

Attachments (2)

6341.patch (471 bytes) - added by Saare 6 years ago.
6341_2.patch (1.6 KB) - added by Saare 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 years ago by Saare

  • Status changed from new to confirmed

We must ensure that the cursor will still work correctly for objects like images and tables.

Changed 6 years ago by Saare

comment:2 follow-up: Changed 6 years ago by Saare

  • Milestone set to CKEditor 3.4.2
  • Owner set to Saare
  • Status changed from confirmed to review

It's for some reason impossible on FF [perhaps a Bugzilla ticket should be filed]. The same usecase didn't work on FF with FCKeditor as well.

comment:3 Changed 6 years ago by garry.yao

  • Status changed from review to review_passed

Actually Webkit is the only that works natively in the way that's expecting by this ticket, the patch doesn't resolve everything but at least give a more consistent style that looks like the desktop experience.

comment:4 in reply to: ↑ 2 Changed 6 years ago by fredck

Replying to Saare:

It's for some reason impossible on FF [perhaps a Bugzilla ticket should be filed]. The same usecase didn't work on FF with FCKeditor as well.

Please do not close this ticket without reporting it to Mozilla.

comment:5 Changed 6 years ago by Saare

  • Status changed from review_passed to review

Fixed with [5903].
I found out that the problem is caused by the fact that the HTML height is not streched to 100%. Proposing a workaround here.

Changed 6 years ago by Saare

comment:6 Changed 6 years ago by garry.yao

  • Status changed from review to review_failed

Did you see a problem with the your committed patch, for me that's enough.

comment:7 Changed 6 years ago by Saare

  • Status changed from review_failed to review

With FF, if the content is shorter than the editor frame, the text cursor will not appear underneath it.

comment:8 Changed 6 years ago by garry.yao

  • Status changed from review to review_failed

Why not making it a generic CSS change (for all browsers) and unify the 'autogrow' plugin accordingly?

comment:9 Changed 6 years ago by Saare

  • Status changed from review_failed to review

Using generic CSS change brings regressions, it's safer just to have this change for FF.

comment:10 Changed 6 years ago by garry.yao

  • Status changed from review to review_passed

comment:11 Changed 6 years ago by Saare

  • Resolution set to fixed
  • Status changed from review_passed to closed

Post fixed by [5929].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy