Ticket #6347 (closed Bug: fixed)

Opened 4 years ago

Last modified 2 years ago

Double request to sprite image files when timestamp enabled

Reported by: tobiasz.cudnik Owned by:
Priority: Normal Milestone:
Component: Project : CKReleaser Version:
Keywords: Cc:

Description

Double request to sprite image files when timestamp enabled. Example:

http://nightly.ckeditor.com/5829/skins/kama/icons.png?t=A7M74HW
http://nightly.ckeditor.com/5829/skins/kama/icons.png

This should be handled in releaser, which should update CSS files with correct timestamp.

Question: What if user disabled timestamp in config ? We can ship 2 versions of each CSS file to handle this. Alternatively, we can inject CSS rule dynamically, but this seems to be much less stable.

Change History

comment:1 Changed 4 years ago by fredck

  • Status changed from new to confirmed
  • Component changed from General to Project : CKReleaser

Considering that the timestamp is used by default, we should have it by default in the CSS as well.

I think that having two sets of CSS files just for this is too much. Having the timestamp hardcoded would not break things. So, we could at least leave it documented that manual changes to the CSS files are needed to avoid timestamp on some image requests.

comment:2 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

I was not able to reproduce this in latest CKEditor 3.x and CKEditor 4.x.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy