Ticket #6401 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Paste: Outline Numbered lists do not copy correctly

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.1
Keywords: IBM Cc: damo, joek, r.blomjous@…

Description

Lists with more than 2 levels and that have the style "Outline Numbered" do not paste correctly. Levels beyond the 2nd level collapse.

This occurs when measurement units is set to: cm, mm or pt.

See attached tc.

Attachments

OutlineNumberedList.doc (25.5 KB) - added by satya 4 years ago.
OutlineNumberedList.2.doc (25.5 KB) - added by satya 4 years ago.
stupidList.docx (11.0 KB) - added by roel.b 4 years ago.

Change History

Changed 4 years ago by satya

Changed 4 years ago by satya

comment:1 follow-up: ↓ 2 Changed 4 years ago by krst

  • Status changed from new to pending
  • Component changed from General to Core : Pasting

I cannot reproduce this issue, with text pasted from attached documents.
Even when I changed measuer units and swityced between browsers. I use word 2010. Maybe it is the difference?

What version of MS Word are You using?

comment:2 in reply to: ↑ 1 Changed 4 years ago by satya

Replying to krst:

I cannot reproduce this issue, with text pasted from attached documents.
Even when I changed measuer units and swityced between browsers. I use word 2010. Maybe it is the difference?

What version of MS Word are You using?

i am using MS word 2003 even we tried with MS Word 2007 same issue happens

comment:3 Changed 4 years ago by roel.b

  • Cc r.blomjous@… added

I did some research at this bug. for me (working with the last svn trunk version), I can reproduce this bug when using office 2007. for me it goes wrong for this html. as you can see the mso-list: level difference is larger than 1

<P style="TEXT-INDENT: -39.6pt; MARGIN: 0cm 0cm 0pt 111.6pt; mso-add-space: auto; mso-list: l1 level5 lfo2" class=MsoListParagraphCxSpMiddle><FONT color=#000000><SPAN style="mso-fareast-font-family: Arial; mso-bidi-font-family: Arial"><SPAN style="mso-list: Ignore"><FONT size=3>1.1.1.1.1000.</FONT><SPAN style="FONT: 7pt 'Times New Roman'">&nbsp;&nbsp;&nbsp; </SPAN></SPAN></SPAN><FONT size=3>j</FONT></FONT></P> <P style="TEXT-INDENT: -72pt; MARGIN: 0cm 0cm 0pt 216pt; mso-add-space: auto; mso-list: l1 level9 lfo2" class=MsoListParagraphCxSpMiddle><FONT color=#000000><SPAN style="mso-fareast-font-family: Arial; mso-bidi-font-family: Arial"><SPAN style="mso-list: Ignore"><FONT size=3>1.1.1.1.1000.1.1.1.1.</FONT><SPAN style="FONT: 7pt 'Times New Roman'">&nbsp;&nbsp;&nbsp; </SPAN></SPAN></SPAN><FONT size=3>k</FONT></FONT></P>

Changed 4 years ago by roel.b

comment:4 Changed 4 years ago by fredck

#6430 has been marked as DUP.

comment:5 Changed 4 years ago by garry.yao

For IE and Safari, I can't reproduce it on all of above three attached doc files, while on Firefox because the blocker of #6662, we're not able to test it.

comment:6 Changed 3 years ago by satya

This one is fixed.Please close this defect.We are getting a different issue with stupidList.docx and we have opened a seperate ticket for this.

comment:7 Changed 3 years ago by garry.yao

  • Status changed from pending to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy