Opened 6 years ago

Closed 5 months ago

Last modified 4 months ago

#6457 closed Bug (fixed)

Word pasting is extremely slow in IE7 and IE8

Reported by: toma25 Owned by:
Priority: Normal Milestone: CKEditor 4.6.0
Component: Plugin : Paste from Word Version: 3.4.1
Keywords: IE Cc:

Description

I've noticed that our typical word document used in our for pasting into the CK editor runs extremely sow in IE7 and IE8. This is true if you compare 3.4.1. between FF 3.5 and IE. Its also true if you compare IE behavior between 3.0.1 and 3.4 in IE. Its a factor 10 or more. Application become unresponsive. I have attached a document that can be used to paste into the editor to see the behavior.

Attachments (1)

big_word_doc_with_tables.doc (1.1 MB) - added by toma25 6 years ago.
A file that takes minutes to paste into editor in IE

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by toma25

A file that takes minutes to paste into editor in IE

comment:1 Changed 6 years ago by garry.yao

  • Resolution set to wontfix
  • Status changed from new to closed

We understand that the filter that we introduced in 3.1 has indeed performance impacts, I'm not saying you should not have such big document, but even you try this with a bare bone browser paste your provided document are far more than seconds.

So we recommend you to provide your own CKEDITOR.cleanWord replacement if you frequently have this kind of monster paste.

CKEDITOR.cleanWord = function( data, editor )
{
   // Your custom content processing.
   return data;
}

comment:2 Changed 6 years ago by toma25

I understand what you are saying. Such an performance decrease (from 3.0.1) should however in my opinion be addressed. In IE7 it takes 100 seconds in FF it takes 12 seconds.

comment:3 Changed 6 years ago by garry.yao

  • Keywords IE added
  • Milestone set to CKEditor 3.6
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Leave this open to gain attention on performance tunning.

comment:4 Changed 6 years ago by krst

  • Status changed from reopened to confirmed

Changing to "confirmed", due it is a known issue

comment:5 Changed 6 years ago by fredck

  • Milestone CKEditor 3.6 deleted

We need a patch here before targeting it.

comment:6 Changed 5 years ago by Tom Robinson

This is not a problem with CKEditor, it is strictly an IE problem. I created this tiny test page:

 <div contenteditable=true>paste here</div>

Pasting your test document from Word into IE9 took over 15 minutes, at which point I gave up. However, if I first pasted/copied through Chrome (3 seconds), then the paste in IE took 1 second. Pasting from Chrome into IE9 CKEditor was also very quick. I'm running Windows 7 64-bit.

comment:7 Changed 3 years ago by j.swiderski

I can confirm what @Tom Robinson has said. This is happening in IE8-10.
I have tried simple textarea or editable div and in both cases this word file has taken ages to get processed.

Since native IE doesn't handle this, neither will editor which works inside native IE.
In editor such paste took about 1-2 min. I was kind of surprised with this fact because it was much faster than in native textarea and a little bit faster than in native editable div.

Last edited 3 years ago by j.swiderski (previous) (diff)

comment:8 Changed 3 years ago by fredck

  • Component changed from Core : Pasting to Plugin : Paste from Word

comment:9 Changed 5 months ago by Tade0

  • Resolution set to fixed
  • Status changed from confirmed to closed

Managed to paste it in 2016 in IE8 with PFW processing. What a time to be alive.

comment:10 Changed 4 months ago by Anna

  • Milestone set to CKEditor 4.6.0
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy