Opened 5 years ago

Closed 2 years ago

#6459 closed Bug (wontfix)

IE: Slow typing speed on IE6

Reported by: tobiasz.cudnik Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE Cc: kenny.demetter@…

Description (last modified by tobiasz.cudnik)

IE6 suffers from slow typing speed using contents from the attachment. Reported to be enterMode BR issue, but it's also present in default configuration.

To reproduce place the cursor at the end of the document and start typing.

Attachments (1)

slow_contents.txt (4.6 KB) - added by tobiasz.cudnik 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by tobiasz.cudnik

comment:1 Changed 5 years ago by tobiasz.cudnik

  • Description modified (diff)
  • Status changed from new to confirmed

comment:2 Changed 5 years ago by tobiasz.cudnik

  • Cc kenny.demetter@… added

comment:3 Changed 5 years ago by wwalc

Tips from Kenny after his research:

I did some research myself and i found the slowness is being caused by a for loop in certain function :

  • in the selection plugin (plugin.js )
  • in the function getBoundaryInformation

There is a for loop there, which seems to go over every node in the editor and check on nodetype = 1 ( element node ).

However, in the case of entermode br, the node there is not an element node. If you follow the for loop, you will see that in that case, it does not perform a return. As such, it will go over the for loop.

The result is that, the more you type, the more nodes, so the longer it takes to execute this function.

comment:4 Changed 2 years ago by j.swiderski

  • Resolution set to wontfix
  • Status changed from confirmed to closed

IE6 is no longer supported in CKE 4.x

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy