Opened 6 years ago

Closed 6 years ago

#6513 closed Bug (fixed)

ARIA list property incorrect in "stylescombo"

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.4.3
Component: Accessibility Version: 3.2
Keywords: Firefox Cc:

Description

Open styles combo and check the the "aria-setsize" attribute that presented on list item link, undefined is found there, it breaks the understanding of list structure for screen readers.

Attachments (2)

6513.patch (364 bytes) - added by garry.yao 6 years ago.
6513_2.patch (616 bytes) - added by fredck 6 years ago.

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by garry.yao

comment:1 Changed 6 years ago by garry.yao

  • Status changed from new to confirmed

comment:2 Changed 6 years ago by garry.yao

  • Milestone changed from CKEditor 3.5 to CKEditor 3.4.3

comment:3 Changed 6 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:4 Changed 6 years ago by fredck

  • Status changed from review to assigned

I'm not able to reproduce this problem. aria-setsize is properly set. Do you have more info?

comment:5 Changed 6 years ago by garry.yao

  • Status changed from assigned to pending

Styles combo/Firefox3.6.12, original message from JAWS team:

 The posinset and setsize values seem to be incorrect on the
"format styles" list.  On
http://nightly.ckeditor.com/5934/_samples/replacebyclass.html click on the
"format styles" button and you get a list of options.  Looking at the
IAccessible information I see strange values for posinset and setsize for
the items in the list (this is a previously reported issue with FF 3.6).

comment:6 Changed 6 years ago by garry.yao

  • Keywords Firefox added

comment:7 Changed 6 years ago by garry.yao

  • Status changed from pending to review

Changed 6 years ago by fredck

comment:8 Changed 6 years ago by fredck

  • Status changed from review to review_failed

It's not my intention to take over the ticket, but considering that it's wrong to access private variables from other parts of the code, I was wondering if the attached solution would be proper to fix it.

If you feel it's ok, please go ahead committing it directly.

comment:9 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_failed to closed

Fixed with [6140].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy