Ticket #661 (closed Bug: duplicate)

Opened 7 years ago

Last modified 7 years ago

[SS] Remove Format does not remove styles

Reported by: krokogras@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: fredck, krokogras@…, cbtrussell@…, flee999@…, oggvorbis@…, jenzener@…

Description

1.) applied styles can only be removed on sourcecode.

2.) applying a style over a style already applied does not remove the old style.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1201919&group_id=75348&atid=543653

Change History

comment:1 Changed 7 years ago by martinkou

  • Reporter changed from martinkou to krokogras@…

Hi krokogras,

I'm sorry for not being able to fix it before. If you take a look in the development history, you will see that we have always taken care of bug fixing, but it is not possible to fix all of them, otherwise we would never have new releases.

Actually bugs related to styles have been grouped to the handled all together. It is quite a huge and delicate task. It has been scheduled for version 2.5.

You can't imagine how anxious I am to have that version ready. I know how important the styles feature is for our community.

We are working to enlarging the team now. Actually, I'm working to provide better tools so people can easily contribute. I'm sure those efforts will help us on being more timely with bug fixings, making everybody happy.

The future of FCKeditor is quite promising and this will be an incredible year for the project. Stay in touch. I'm sure you will enjoy it.

Best regards, FredCK

PS: Sorry for being a little bit "sarcastic" in my other comment, but some kinds of comments simply deserve it.


Moved from SF. Original poster: fredck

hi fred, sorry to say this: i have reported this bug at the start of release 2.0. There has been quite an amount of response and agreement with this bug-statement. Dont you think that a fix could be scheduled earlier than 8 releases later?


Moved from SF. Original poster: krokogras

Fred - thanks for the update. Per my original comment below we are anxiously awaiting a fix to this as well. Glad to hear it's on the map for 2.5!

And for the record, fckeditor is MUCH better than tinymce :-)


Moved from SF. Original poster: cbtrussell

Dear "nobody",

I'm sorry to say that, but in the "real spirit of open source :-(((", people interested on a feature or a fix, simply sit down and start coding, proposing a well written patch for it, instead of laying there just talking. Just to let you know, there is a lot of people here working to provide the software you are using for free, and they are doing it really well.

Back to the bug report (the real subject here), this issue will be addressed in the next version, as stated before (does anyone said 2008 here? No, "nobody" said that)... shouldn't we be happy with it?


Moved from SF. Original poster: fredck

Fredrick,

Thanks alot for your prompt response, this really is in the spirit of open-source...as I would never have received more than a bulk reply from any commercial entity.


Moved from SF. Original poster: flee999

This is the real spirit of open source :-((( issue reported in 2005, maybe will be fixed in 2008 i am glad that tinymce exists.


Moved from SF. Original poster: Anonymous

We are about to launch version 2.4. This issue (marked with [SS]) is planned to be fixed for version 2.5.


Moved from SF. Original poster: fredck

This is still a problem in 2.3.2 (for IE only). I also just tested it in the nightly build (as of Jan 23 2007) and the problem is still there.

This is a HUGE issue for us, and it is obviously for other, too because there a couple more requests that look exactly like this

  • 1326920
  • 1196215

Whatever you guys could do to prioritize this would be greatly appreciated. I see this problem has been around since 2005, maybe we can sponsor this fix in 2007 :)


Moved from SF. Original poster: flee999

I'm marking this bug to [SS] (Style Selector).


Moved from SF. Original poster: fredck

have upgraded priority, maybe this helps


Moved from SF. Original poster: krokogras

This remains an issue in 2.3 - remove format button works perfectly in FF 1.5, but does not work at all for IE.

This is a showstopper for us, willing to sponsor a fix. Please advise if this is going to be addressed in a upcoming release.

Thank you!


Moved from SF. Original poster: cbtrussell

Why is this bug still open without any comments of the developers? It has been reported over a year ago! For many people this nasty bug is a big showstopper. In IE there is now no single way to remove a style applied to a text without diving into the HMTL source. So the whole style functionality is unusable for IE users.


Moved from SF. Original poster: oggvorbis

Seems like this bug is still alive. 1) just in IE 2) IE and Firefox 1.0.6


Moved from SF. Original poster: jenzener

comment:2 Changed 7 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to duplicate

This is a dup of #75

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy