Opened 6 years ago

Closed 5 years ago

#6614 closed Bug (fixed)

Resize handler in RTL UI

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: UI : Toolbar Version:
Keywords: Cc:

Description

Now resize handler is placed at "l-b" in RTL UI language, this create a broken dragging experience as editor chrome is left-aligned in host page (expands at right hand side) when dragging.

Attachments (3)

6614.patch (2.8 KB) - added by garry.yao 5 years ago.
6614_2.patch (3.7 KB) - added by garry.yao 5 years ago.
6614_3.patch (8.5 KB) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by Saare

  • Keywords Discussion removed
  • Status changed from new to confirmed

The editor should definitely be resized to the opposite side.

comment:2 Changed 5 years ago by wwalc

  • Milestone set to CKEditor 3.5.2

comment:3 Changed 5 years ago by Saare

Note: when the editor is placed inside a RTL container, it does resizes correctly.

Changed 5 years ago by garry.yao

comment:4 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

Totally 4 scenarios targeted, editor UI direction(2) * editor environment direction(2)

comment:5 Changed 5 years ago by Saare

  • Status changed from review to review_failed

Dialog resizing was also affected.

Changed 5 years ago by garry.yao

comment:6 Changed 5 years ago by garry.yao

  • Status changed from review_failed to review

Dialog case is a bit different, because of the modal-less nature, resize handler could reflect simply the UI direction.

Changed 5 years ago by garry.yao

comment:7 Changed 5 years ago by garry.yao

Switch to use CSS "right" for dialog positioning, while keep dialog::move back-compat, in this way the RTL resize logic are much simpler.

comment:8 Changed 5 years ago by Saare

  • Status changed from review to review_passed

comment:9 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6454].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy