Ticket #6649 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Delete Table option is not working

Reported by: souravmoysau Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: UI : Dialogs Version: 3.4.2
Keywords: Cc:

Description

Hi, The delete table option[ select a table and then right click and select Delete Table] is not working. Rather deleting the selected table it slects the content of the table. Workaround: Cut and paste the table.The choose the delete option,then the delete will work !!!!!!!!

Attachments

6649.patch (1.0 KB) - added by garry.yao 4 years ago.
6649_2.patch (3.6 KB) - added by garry.yao 4 years ago.

Change History

comment:1 in reply to: ↑ description Changed 4 years ago by souravmoysau

Hi, one thing forget to mention the browser version. it is IE7 Replying to souravmoysau:

Hi, The delete table option[ select a table and then right click and select Delete Table] is not working. Rather deleting the selected table it slects the content of the table. Workaround: Cut and paste the table.The choose the delete option,then the delete will work !!!!!!!!

comment:2 follow-up: ↓ 3 Changed 4 years ago by garry.yao

  • Status changed from new to pending

Works for me on trunk, can you provide more information?

comment:3 in reply to: ↑ 2 Changed 4 years ago by souravmoysau

Replying to garry.yao:

Works for me on trunk, can you provide more information?

hi, i have tested on the demo linkhttp://ckeditor.com/demo.In Ie7 The steps i followed is as below 1.Move cursor to the border of the table. 2.move cursor appear,left clicked 3.the table showing selected. 4.right clicked and select "Delete Table". 5.The table content get selected.

comment:4 Changed 4 years ago by garry.yao

  • Status changed from pending to confirmed

Changed 4 years ago by garry.yao

comment:5 Changed 4 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:6 Changed 4 years ago by garry.yao

  • Keywords HasPatch added
  • Status changed from review to assigned

Only occurs when the object selection made on table (border click) instead of text selection inside of it.

comment:7 Changed 4 years ago by wwalc

  • Milestone set to CKEditor 3.5.2

comment:8 Changed 4 years ago by garry.yao

  • Keywords HasPatch removed
  • Status changed from assigned to review

Reduced TC:

  1. Left click on table border to show handler;
  2. Right click at the same position to open context menu;
  3. Press "Esc" to close menu;
    • Actual Result: selection is NOT at the table.

Changed 4 years ago by garry.yao

comment:9 Changed 4 years ago by Saare

  • Status changed from review to review_passed

comment:10 Changed 4 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6559].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy