Opened 6 years ago

Closed 6 years ago

#6670 closed Bug (fixed)

BIDI: Indent & List icons are not reversed when we apply RTL direction to a paragraph with any of Paragraph Formatting options

Reported by: satya Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.4.3
Component: Core : BiDi Version: 3.4.2
Keywords: IBM Cc: damo, joek, james c

Description

To reproduce the defect:

  1. Open the Ajax sample.
  1. Type some text, select the text & apply any of the Paragraph Formatting options(H1 to H6 or Address etc).
  1. Click on RTL icon.

Expected Result:

Direction of list & indent icons should be reversed to reflect the change to RTL language direction.

Actual Result:

Direction of list & indent icons are not reversed to reflect the change to RTL language direction.

Attachments (2)

6670.patch (1.3 KB) - added by tobiasz.cudnik 6 years ago.
6670_2.patch (608 bytes) - added by tobiasz.cudnik 6 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by tobiasz.cudnik

  • Milestone set to CKEditor 3.4.3
  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

Changed 6 years ago by tobiasz.cudnik

comment:2 Changed 6 years ago by tobiasz.cudnik

  • Status changed from assigned to review

comment:3 follow-up: Changed 6 years ago by garry.yao

  • Status changed from review to review_failed

For me we could simply check the computed direction of the path block/blockLimit?

Changed 6 years ago by tobiasz.cudnik

comment:4 in reply to: ↑ 3 Changed 6 years ago by tobiasz.cudnik

  • Status changed from review_failed to review

Replying to garry.yao:

For me we could simply check the computed direction of the path block/blockLimit?

Right, it seems to be a simpler approach which still fixes the problem.

comment:5 Changed 6 years ago by garry.yao

  • Component changed from General to Core : BiDi
  • Status changed from review to review_passed

comment:6 Changed 6 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6094].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy