Opened 5 years ago

Closed 5 years ago

#6747 closed Bug (fixed)

Maximize Issue with Toolbar in Firefox 3.x and IE 8

Reported by: ansarisufiyan Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.4.3
Component: General Version: 3.3
Keywords: Cc: jamcunni@…

Description

When I maximized the editor control in FF 3.x/IE 8 and clicked on the editor's content area then some of the options of toolbar gets invisible. To reproduce this issue, we can simply check the demo page's Skin example found at URL: http://ckeditor.com/demo. To reproduce this issue, simply maximized the 2nd or 3rd editor and then click on the editor's content area. I have attached the snapshots for both 2nd and 3rd editor controls, given in the Skin demo.

Attachments (5)

2nd Editor (Office2003 Skin).JPG (49.0 KB) - added by ansarisufiyan 5 years ago.
3rd Editor (V2 Skin).JPG (47.7 KB) - added by ansarisufiyan 5 years ago.
6747.patch (968 bytes) - added by Saare 5 years ago.
6747_2.patch (1.5 KB) - added by garry.yao 5 years ago.
6747_3.patch (1.1 KB) - added by tobiasz.cudnik 5 years ago.

Download all attachments as: .zip

Change History (17)

Changed 5 years ago by ansarisufiyan

Changed 5 years ago by ansarisufiyan

comment:1 Changed 5 years ago by tobiasz.cudnik

  • Status changed from new to confirmed

Confirming on FF using the V2 skin on the skins sample. There is a quite long delay before the editor gets maximized.

comment:2 Changed 5 years ago by fredck

  • Milestone set to CKEditor 3.5.1
  • Version set to 3.3

I can confirm it with FF with both the office2003 and v2 skins, using the skins sample. It has been introduced with the 3.3. Works well with the 3.2.2.

The trick to reproduce it is clicking in the white area bellow the editor contents.

Unlike Tobiasz, I see no delay on the maximization.

This is quite a severe issue, because it makes the toolbar hidden so users are not able to restore the editor size.

comment:3 Changed 5 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from confirmed to assigned

comment:4 Changed 5 years ago by garry.yao

  • Milestone changed from CKEditor 3.5.1 to CKEditor 3.4.3

Affects any scrolled page and skin independent prioritize it.

comment:5 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [6164].

comment:6 Changed 5 years ago by james c

  • Cc jamcunni@… added

This defect is still reproducible in the Skins sample, V2 skin, IE8 non-compatibility & should be reopened

comment:7 Changed 5 years ago by Saare

  • Resolution fixed deleted
  • Status changed from closed to reopened

Confirmed the bug isn't fixed.

Changed 5 years ago by Saare

comment:8 Changed 5 years ago by Saare

  • Owner changed from tobiasz.cudnik to Saare
  • Status changed from reopened to review

Changed 5 years ago by garry.yao

comment:9 Changed 5 years ago by garry.yao

  • Status changed from review to review_failed

Previous patch failed in Opera when using mouse wheel (cause page scroll).

Changed 5 years ago by tobiasz.cudnik

comment:10 Changed 5 years ago by tobiasz.cudnik

  • Owner changed from Saare to tobiasz.cudnik
  • Status changed from review_failed to review

comment:11 Changed 5 years ago by Saare

  • Status changed from review to review_passed

R+ for 6747_2.

comment:12 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6224].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy