Ticket #6781 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

[IE7] Dialogs are broken with RTL and office2003 and v2 skins

Reported by: Saare Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.4.3
Component: UI : Skins Version: 3.4.2
Keywords: IE Cc:

Description

Dialog layout is broken in IE8's IE7 mode, when using RTL and the office2003 and v2. A regression of the 3.4.2.

Attachments

6781.png (17.5 KB) - added by Saare 4 years ago.
6781.patch (828 bytes) - added by tobiasz.cudnik 4 years ago.

Change History

Changed 4 years ago by Saare

comment:1 Changed 4 years ago by tobiasz.cudnik

  • Status changed from new to assigned
  • Owner set to tobiasz.cudnik

comment:2 Changed 4 years ago by tobiasz.cudnik

Regression of [5897].

Changed 4 years ago by tobiasz.cudnik

comment:3 Changed 4 years ago by tobiasz.cudnik

  • Status changed from assigned to review

comment:4 Changed 4 years ago by Saare

  • Status changed from review to review_failed

The patch doesn't fix the bug for me [IE8's IE7 mode].

comment:5 Changed 4 years ago by tobiasz.cudnik

Are you sure it's not a cache issue? I completely cannot reproduce it with the patch applied using both IE8/IE7 and IE7.

comment:6 Changed 4 years ago by garry.yao

Confirmed in IE7 standards on both trunk and 3.5.x

comment:7 Changed 4 years ago by garry.yao

Patch works, but once start dragging, buttons in the footer disappears.

comment:8 Changed 4 years ago by tobiasz.cudnik

Disappearing buttons are a different regression, which is now covered by #6798.

comment:9 Changed 4 years ago by wwalc

The attached patch works for me as well.

comment:10 Changed 4 years ago by tobiasz.cudnik

  • Status changed from review_failed to review

comment:11 Changed 4 years ago by Saare

  • Status changed from review to review_passed

Ugh, my bad.. I've applied the patch on the wrong place. Sorry for that.

comment:12 Changed 4 years ago by tobiasz.cudnik

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6187].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy