Ticket #6795 (closed Bug: fixed)

Opened 4 years ago

Last modified 15 months ago

SCAYT Languages tab should contain some spacing between the radio buttons and labels

Reported by: Anna Owned by: Anna
Priority: Normal Milestone:
Component: UI : Spell Checker Version:
Keywords: HasPatch Cc: tech@…

Description

The "Languages" tab of the Spell Check As You Type dialog window would benefit from some spacing between the radio buttons and their labels, similar to the formatting of the "Options" tab & its checkboxes. Right now it looks a bit crammed/ ugly.

Languages tab: http://docs.cksource.com/images/b/b4/CKEditor_SCAYT_languages.png

Options tab: http://docs.cksource.com/images/b/b6/CKEditor_SCAYT_options.png

Attachments

6795.patch (1.8 KB) - added by SpellChecker.net 4 years ago.

Change History

comment:1 Changed 4 years ago by SpellChecker.net

  • Cc tech@… added
  • Component changed from UI : Dialogs to UI : Spell Checker

comment:2 Changed 4 years ago by krst

  • Status changed from new to confirmed

Changed 4 years ago by SpellChecker.net

comment:3 Changed 4 years ago by SpellChecker.net

  • Keywords HasPatch, Review? added

Spacing between the radio buttons and labels added.

comment:4 Changed 3 years ago by Anna

  • Owner set to Anna
  • Status changed from confirmed to review
  • Keywords HasPatch added; HasPatch, Review? removed

comment:5 Changed 3 years ago by Anna

  • Status changed from review to review_failed

This solution does not really work as expected, since it still looks bad for Right-to-Left languages.

Besides, in CKEditor we tend to use a space placed between the checkbox/radio element and the label, like in here: https://dev.ckeditor.com/browser/CKEditor/trunk/_source/plugins/dialogui/plugin.js#L391. This helps save a couple of bytes when compared to adding multiple style declarations.

Would you be able to implement something along these lines instead? Thanks!

comment:6 Changed 15 months ago by Anna

  • Status changed from review_failed to closed
  • Resolution set to fixed

This is no longer a problem in current versions of WSC. Closing as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy