Ticket #6865 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

BiDi buttons are not reflected when a change is done through a dialog

Reported by: Saare Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: Core : BiDi Version: 3.4
Keywords: Cc:

Description

  • Open a sample and create a div.
  • Note that the toolbar icon shows LTR.
  • Right click on the div, and choose edit div.
  • Go to the advanced tab and choose the RTL from the Language Direction dropdown.
  • Click OK.

Note that the toolbar icon shows LTR.

Attachments

6865.patch (3.8 KB) - added by garry.yao 4 years ago.
6865_2.patch (801 bytes) - added by garry.yao 3 years ago.
6865_3.patch (6.0 KB) - added by garry.yao 3 years ago.
6865_4.patch (4.3 KB) - added by garry.yao 3 years ago.
6865_5.patch (4.7 KB) - added by garry.yao 3 years ago.

Change History

Changed 4 years ago by garry.yao

comment:1 Changed 4 years ago by garry.yao

  • Status changed from new to review
  • Owner set to garry.yao

comment:2 Changed 3 years ago by wwalc

  • Milestone set to CKEditor 3.5.2

comment:3 Changed 3 years ago by Saare

  • Status changed from review to review_failed
  • There're missing fields now (language code & title) and we already have the css class field in the general tab.
  • It's impossible to edit class names of the div through the general tab (maybe becuase the same field appears on both tabs).
  • Note that the way we handle styles from the styles set is not treated.

Changed 3 years ago by garry.yao

comment:4 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

This's just a temporary fix, we need to seek for a way of firing this event at element::setAttribute(s) level or even by "DOMAttrModified" event.

comment:5 Changed 3 years ago by Saare

  • Status changed from review to review_failed

The div dialog was just an example, also affects other dialogs (e.g. link). Let's find a way to trigger the event on attribute modification in general.

comment:6 Changed 3 years ago by Saare

  • Milestone CKEditor 3.5.3 deleted

My bad, the link dialog is not a good example as the buttons only care about block level elements (maybe a point of thought?). All in all, this is an R- as the patch doesn't work for me, anyway we should still seek for a more dynamic way.

comment:7 Changed 3 years ago by Saare

  • Milestone set to CKEditor 3.5.2

comment:8 Changed 3 years ago by Saare

  • Milestone changed from CKEditor 3.5.2 to CKEditor 3.5.3

Changed 3 years ago by garry.yao

comment:9 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review
  • Version set to 3.4

Ok now a generic solution proposed.

comment:10 Changed 3 years ago by Saare

  • Status changed from review to review_failed

Note that el.setAttribute( 'style', 'sthg' ) is not the same as el.setStyle( 'sthg', 'sthg' ), so we can't map setAttribute to setStyle in that sense.

Changed 3 years ago by garry.yao

comment:11 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

I'd not go with style parsing approach to NOT bring a performance impacts.

comment:12 Changed 3 years ago by Saare

  • Status changed from review to review_failed
  • Trying to insert a table results in a js error.
  • We should also consider removeAttribute and removeStyle.

Changed 3 years ago by garry.yao

comment:13 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

Trying to insert a table results in a js error.

Cannot reproduce this issue.

TC added with [6474].

comment:14 Changed 3 years ago by Saare

  • Status changed from review to review_passed

comment:15 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6478].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy