Ticket #6877 (closed Bug: invalid)

Opened 3 years ago

Last modified 3 years ago

bug in your samples in CKEditor 3.4.2

Reported by: tkilshaw Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.2
Keywords: samples Cc:

Description

This will be the fourth time that I have reported this problem via a ticket. All three previous attempts were cancelled by the bug reviewer. This is for me, in part, an evaluation of how your company responds to feedback. So far you don't get a passing grade.

First here is the bug report:


I got the latest CKEditor version: 3.4.2 and put it on my tomcat6 server.

I accessed the samples and clicked on "Replace textareas by class name".

When that sample appeared, I clicked the Submit button.

On the screen under the CKEditor - Posted Data heading you can see:

$value ) { if ( get_magic_quotes_gpc() ) $postedValue = htmlspecialchars( stripslashes( $value ) ) ; else $postedValue = htmlspecialchars( $value ) ; ?>

The same problem appears on any of the samples that have a submit button.

I'm using tomcat6 on XP with service pack 3. Browser was Chrome 8.0 but IE 6 had the same problem.

Using Firefox on Windows 7 produced the same result.


My previous ticket 6052 was marked as a duplicate of 6844 and 6844 was marked as invalid.

But its not invalid. I get the same results every time I try your examples.

If there is a resolution of this please indicate what it is instead of just marking my feedback as invalid.

Having looked back at the the FCKEditor Samples, I guess that the sample I tried is supposed to show a table with data values from the submit. Instead it just spews out the aforementioned JavaScript above the first part of the data value table.

Please contact me if you need me to show you this problem. But please stop marking it as invalid without some explanation.

If it is invalid, why is it invalid?

Are you unable to reproduce the problem?

Or when you reproduce the problem do you think that spewing JavaScript onto the screen is the expected behaviour?

thanks,

Terry

Change History

comment:1 Changed 3 years ago by wwalc

  • Status changed from new to closed
  • Resolution set to invalid

The source of the problem will be handled in a separate ticket: #6880.

In short: you are using a tomcat6 server which supports Java server side language. The file we are distributing along with CKEditor as an example is written in PHP language which your server cannot handle.

It doesn't mean that you can't use CKEditor with Java. It only means that to save the content sent from CKEditor, you should write your own Java code, that saves the data coming from a HTML form. One of the samples is available here: http://www.java2s.com/Tutorial/Java/0360__JSP/SaveFormInputtoFileusingJSP.htm

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy