Ticket #6941 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

horizontal scrollbar in firefox

Reported by: holger Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5
Keywords: Firefox HasPatch Cc: Saare

Description

which only occurs in the initialization for 1 second to and is dependent on their parents' style

you need to change

_source/plugins/wysiwygarea/plugin.js line 537

from

element.setStyles( { position : 'absolute', top : '-3000px' } );

to

element.setStyles( { position : 'absolute', left: '-3000px', top : '-3000px' } );

Attachments

test.html (638 bytes) - added by holger 4 years ago.
testcase

Change History

comment:1 Changed 4 years ago by alfonsoml

  • Keywords Firefox HasPatch added

comment:2 Changed 4 years ago by garry.yao

  • Status changed from new to pending

Could you provide a test case that shows the scrollbar?

Also, #5956 must be re-checked as there's no originate TC and I was unable to reproduce it in FF.

Changed 4 years ago by holger

testcase

comment:3 Changed 4 years ago by holger

the reason is the style 'overflow:auto' in the testcase.

and the patch was not complete. i have forget to save the original left value.

previousStyles = {

position : element.getStyle( 'position' ), left : element.getStyle( 'left' ) top : element.getStyle( 'top' )

};

element.setStyles( { position : 'absolute', left: '-3000px', top : '-3000px' } );

comment:4 Changed 4 years ago by holger

Is nobody interested on the bug?

comment:5 Changed 4 years ago by holger

what is wrong?

comment:6 Changed 4 years ago by garry.yao

  • Status changed from pending to confirmed

Regression of [5835], we need to verify the original TC at #5956.

comment:7 Changed 4 years ago by garry.yao

  • Cc Saare added

comment:8 Changed 3 years ago by Saare

We cannot use the left property because of our need for RTL compatibility. I'm not sure how much we can do in this sense to make it work well with overflowing parent, as also the regular way to check if right or left should be used will fail with them.

comment:9 Changed 3 years ago by garry.yao

For me, #5956 is simply not reproducible (or at least it's missing a tc), even if it's valid, hidden/opacity fix should be considered in prior to an offset hack.

comment:10 Changed 3 years ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to fixed

Expired on trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy