Ticket #7176 (closed Bug: fixed)

Opened 4 years ago

Last modified 9 months ago

IE9 - SCAYT enabled, after inserting template, dialog does not close. js error thrown

Reported by: krst Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.5.1
Keywords: IE9, IE8 Cc: SpellChecker.net, camden.michael@…, public@…

Description

Environment

IE9 in IE9 mode / Document mode IE9 standards

TC

  • enable SCAYT
  • press "Insert template" button
  • select one of templates

Expected result

Template is added to editor area, dialog is closed.

Actual result

  • template is added to edit area
  • dialog is still visible

in console, errors are thrown:

SCRIPT70: Permission denied 
_base.xd.js, line 3458 character 1
SCRIPT70: Permission denied 
_base.xd.js, line 5624 character 1

When SCAYT is disabled, everything is as expected.

Change History

comment:1 Changed 4 years ago by wwalc

  • Status changed from new to confirmed
  • Component changed from UI : Dialogs to UI : Spell Checker

comment:2 Changed 4 years ago by krst

Still occurs in IE9 final/ CKE r6559

SCRIPT5022: Tried to register widget with id==scayt_0 but that id is already registered 
_base.xd.js, line 880 character 1

comment:3 Changed 4 years ago by mrfr0g

  • Cc camden.michael@… added
  • Keywords IE9,IE8 added; IE9 removed

Also occurs on IE8 in 3.5.2

comment:4 Changed 4 years ago by petersendidit

  • Cc public@… added

comment:5 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

I was not able to reproduce it anymore in latest CKEditor 3.6.5

comment:6 Changed 9 months ago by wwalc

  • Keywords IE9, IE8 added; IE9,IE8 removed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy