Opened 5 years ago

Closed 5 years ago

#7334 closed Bug (fixed)

IE Increasing indentation once of RTL Numbered/Bulleted not shown properly in editor body

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.4
Keywords: IBM IE Cc: tmonahan, jamescun, damo

Description

To reproduce the defect:

  1. Open Editor and create a RTL Numbered/Bulleted list.
  1. Select the entire list and click on Increase Indent icon once.

Expected Result:

Numbered/Bulleted list is indented once and it is moved to the left by 40 pixels.

Actual Result:

Numbered/Bulleted list is indented once but the list not moved to left by 40 pixels ans stays in the same place.

when we look at HTML Source a margin-right:40px is applied to list

  1. Now select the list and click on Decrease Indent icon once.

Expected Result:

Indentation applied to Numbered/Bulleted list is removed and it is moved to right by 40 pixels.

Actual Result:

Indentation applied to Numbered/Bulleted list is removed but the list not moved to right by 40 pixels and it stays in the same place.

Attachments (1)

7334.patch (439 bytes) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by krst

  • Keywords IE7 IE8 added; IE removed
  • Status changed from new to confirmed
  • Version changed from 3.5.3 (SVN - trunk) to 3.4

Occurs since CKE v3.4. IE7/8, while under IE9 it works OK.

Changed 5 years ago by garry.yao

comment:2 Changed 5 years ago by garry.yao

  • Cc changed from tmonahan,jamescun,damo to tmonahan, jamescun, damo
  • Keywords IE added; IE7 IE8 removed
  • Owner set to garry.yao
  • Status changed from confirmed to review

@krst, WFM on IE8 also, can you confirm that? It looks like a browser default style issue.

comment:3 Changed 5 years ago by fredck

  • Status changed from review to review_passed

this is ok with IE8 as well.

comment:4 Changed 5 years ago by fredck

  • Milestone set to CKEditor 3.6.1

comment:5 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6922].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy