Ticket #7342 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 weeks ago

copying and pasting a table doesn't result in its content appearance being preserved in IE8

Reported by: IBM_RQM Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.5.1
Keywords: IBM IE Cc: satya_minnekanti@…

Description (last modified by fredck) (diff)

  1. Enter some text in a empty rich text editor using default font and size.
  2. Change font size to 18 and continue typing in additional text.
  3. Change font size to 26 and foreground color to dark blue and continue typing in additional text.
  4. Hit enter (notice the size of the cursor)
  5. Insert a new table at the current cursor position (accepting defaults)
  6. Enter text into the table
  7. Select the table
  8. Place the cursor after the text entered in step 3 and hit Enter.
  9. Paste the table (using the Paste toolbar button or Ctrl+V).

Result: I expected the text in the pasted table to appear like it did in the copied table, but instead it appeared with the same font size and foreground coloring as the text preceding the table

NOTE: this works as expected in Firefox

Change History

comment:1 Changed 4 years ago by fredck

  • Description modified (diff)

comment:2 Changed 4 years ago by fredck

  • Keywords IE added
  • Status changed from new to confirmed
  • Component changed from General to Core : Pasting

Confirmed with IE.

comment:3 Changed 4 years ago by satya

  • Cc satya_minnekanti@… added

comment:4 Changed 3 weeks ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

I cannot reproduce this TC any more. Most likely it was fixed in CKEditor 4.0 when we started using custom insertHtml method to handle pasting.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy