Ticket #7356 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Style::removeObjectStyle something might be wrong

Reported by: alfonsoml Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: 3.4.1
Keywords: Discussion Cc:

Description

At the very least, in that function the

	var styles = CKEDITOR.style.getStyleText( def );

isn't used, but the final part to remove the style has remained that way since it was created in [5847] that changed also the applyObjectStyle but was reverted in [5978]

So a little clean up is needed there, deciding if it must use getStyleText or def.Styles (but using a local variable), and correcting the comments.

Change History

comment:1 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed
  • Keywords Discussion added

All I can say that this still occurs in CKEditor 3.6 and that I'm putting it on discussion.

comment:2 Changed 4 years ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to fixed

Fixed with [7082].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy