Ticket #7364 (closed Bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

IE8: Extra empty list item is added to a list when using backspace to delete an outer list item

Reported by: jamescun Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: 3.0
Keywords: IE8 IBM Cc: damo, satya, tmonahan, torque18@…

Description

Steps to reproduce the defect:

  1. Open the Ajax sample in IE8.
  1. Paste in the following code.
<ol>
	<li>list item 1
		<ol>
			<li>list item 2</li>
		</ol>
	</li>
	<li>list item 3</li>
</ol>
  1. Place the cursor at the end of the last list item.
  1. Use backspace to delete the last list item so that the cursor is now at the end of the second list item.

Result: An extra empty list item is added underneath the second list item (see screenshot).

Attachments

IE8_Backspace_List_Defect.JPG (25.0 KB) - added by jamescun 3 years ago.

Change History

Changed 3 years ago by jamescun

comment:1 Changed 3 years ago by krst

WFM on rev6593

comment:2 Changed 3 years ago by jamescun

I can still reproduce it on http://rev.ckeditor.com/ckeditor/trunk/6593/_samples/ajax.html in IE8 strict.

comment:3 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed

An extra list element shows under IE8 if you remove list item in wysiwyg mode.

comment:4 follow-up: ↓ 7 Changed 3 years ago by wwalc

I am unable to reproduce in both in IE8/Win7 EN and in IE8/XP EN.

comment:5 Changed 3 years ago by j.swiderski

  • Version changed from 3.5.3 (SVN - trunk) to 3.0

Occurs in IE8 since CKEditor version 3.0

comment:6 Changed 3 years ago by torque18

  • Cc torque18@… added

This may not be directly related, but also only occurs in IE. I did not want to create a new ticket unless this is in fact unrelated.

Paste in the following code:

	<ul>
	<li>item 1</li>
	<li>item 2</li>
	</ul>
	<p>paragraph</p>

In editing view, place your cursor in front of the word "paragraph" and hit backspace once. Return to source view and you will see it has created the following invalid html:

	<ul>
	<li>item 1</li>
	<li>item 2</li>
	paragraph</ul>

In the editing view, if you then change the list formatting (such as from unordered to ordered list) it will "correct" the invalid html it created by deleting the paragraph entirely. You can try this with a large paragraph instead of just the word paragraph, and you will see the whole paragraph disappear from the document.

comment:7 in reply to: ↑ 4 Changed 3 years ago by garry.yao

Replying to wwalc:

I am unable to reproduce in both in IE8/Win7 EN and in IE8/XP EN.

Can be confirmed on IE8/XP only, WFM with IE9/Win7.

comment:8 Changed 3 years ago by satya

Please close this as a duplicate of #8248

Last edited 3 years ago by j.swiderski (previous) (diff)

comment:9 Changed 3 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to duplicate

DUP of #8248

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy