Ticket #7534 (closed Bug: invalid)

Opened 3 years ago

Last modified 3 years ago

Cursor is lost and backspace problem after aplying style display:none to a parent container

Reported by: IBM_RQM Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.2
Keywords: Cc:

Description

When the parent container changes style from display:none to display:block, the cursor is not visible and if you press backspace, ALL previous content is deleted.

I created a very simple html to show the problem, to reproduce:

-extract ckeditor zip on any directory -put the attached file "sample.html" just before the ckeditor folder example:

/sample.html /ckeditor/(ckeditor.js and all other ck files)

-open sample.html -Write something in the editor -Press the "hide Editor" button -Press the "show Editor" button *notice the cursor is lost, and you can't know your current position* -Write something else -Press backspace key *All content is lost

Attachments

sample.html (770 bytes) - added by IBM_RQM 3 years ago.

Change History

Changed 3 years ago by IBM_RQM

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to pending

I have tested your example and didn't get the behavior you were talking about.

After clicking the "show button" cursor was lost from editor because focus stayed on a button. I have clicked inside editor to gain focus, wrote few letters and pressed backspace. Text didn't disappear, only the last letter was deleted.

I have noticed that you have set 3.5.2 version. Have you tested the example with the newest stable release (3.5.3)? Does the problem occur also there?

comment:2 Changed 3 years ago by IBM_RQM

  • Status changed from pending to closed
  • Resolution set to invalid

I discovered that this behavior was caused due to a old lotus plugin, removing it from the configuration file solved the problem. Thanks for your support.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy