Ticket #7569 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

JAWS not reading updated label of Unlock/Lock ratio icon on Image Properties dialog

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone:
Component: Accessibility Version: 3.5.3
Keywords: IBM Cc: damo, jamescun, tmonahan

Description

To reproduce the defect:

  1. With JAWS on, Open Image properties dialog and Navigate to Unlock Ratio button.
  1. JAWS reads the label properly and say press space bar to activate.
  1. when user presses space bar, label changes from Unlock Ratio to lock Ratio and Icon also changes

Expected Result:

JAWS should read out the changed label to the user

Actual Result:

JAWS not reading the new label to the user,it just reads press space bar to activate the button.

Attachments

7569.patch (1.8 KB) - added by garry.yao 3 years ago.
7569_2.patch (2.0 KB) - added by garry.yao 3 years ago.
7569_3.patch (2.2 KB) - added by garry.yao 3 years ago.

Change History

comment:1 Changed 3 years ago by fredck

  • Status changed from new to confirmed
  • Cc changed from damo,jamescun,tmonahan to damo, jamescun, tmonahan

Changed 3 years ago by garry.yao

comment:2 Changed 3 years ago by garry.yao

  • Status changed from confirmed to review
  • Owner set to garry.yao

It's impossible to have JAWS read the (updated) label again on a button, perhaps the right way is to implement it as checkbox instead.

comment:3 Changed 3 years ago by fredck

  • Status changed from review to review_failed

This idea is very good. I would just ask you to make the opposite, calling the button "Lock sizes", being it "checked" by default.

The fact is that two text fields, by default, have no correlation. By calling it "Lock sizes", we clearly justify the default "special" behavior of the fields. It tells the user that, by default, the fields got locked.

Changed 3 years ago by garry.yao

comment:4 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

Make sense

comment:5 Changed 3 years ago by fredck

  • Status changed from review to review_failed

Almost there, but I'm testing it with JAWS and it's reading it as "Undefined checkbox".

I think that, for better usability for non AT users, we can keep the current behavior of changing the title when clicking (so the tooltip gets updated), but use the aria-describedby for AT users. It's a matter of checking if JAWS will like it.

Also... my mistake... when I've said "Lock sizes", I didn't look at the labels we're using right now. I wanted to point out the "Lock/Unlock" thing, not really "sizes". In fact, "Lock ratio" is a much better label for it and should not have changes. Sorry for it.

Changed 3 years ago by garry.yao

comment:6 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

but I'm testing it with JAWS and it's reading it as "Undefined checkbox".

WFM, guess it's caused by non-en language.

I think that, for better usability for non AT users, we can keep the current behavior of changing the title when clicking (so the tooltip gets updated)...

Sounds nice but actually not a good move, JAWS prefers reading title over an aria label, so title and aria label must be kept consistent always.

comment:7 Changed 3 years ago by fredck

  • Status changed from review to review_passed

comment:8 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6952].

comment:9 Changed 3 years ago by damo

The usage of ARIA checkbox seems appropriate in this case.

Although it seems like there may be a problem in High Contrast mode. The label does not change in HC mode and no other indications are presented to the user to indicate the changed value.

Can this be addressed in this ticket or does it need a new one opened?

comment:10 Changed 3 years ago by fredck

@damo, please open a new ticket for it. Being this a regression, we'll handling it immediately for the 3.6.1.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy