Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#7584 closed Bug (fixed)

Start Value not shown correctly for Numbered lists Paste from Word

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: Plugin : Paste from Word Version: 3.5.3
Keywords: IBM Cc: damo, jamescun, tmonahan

Description

To reproduce the defect:

  1. Copy the list from attached word doc and paste it using Paste from Word dialog.
  1. Check for the Start value for the list in Numbered List Properties dialog.

Expected Result: It should show start value as 5.

Actual Result: It shows start value as 1.

  1. Try to change the Start Value to 10 and press OK button.

Expected Result: Numbered list should start at 10.

Actual Result: Numbered list still start at 5.

Attachments (4)

Numbered list with diff start value.doc (24.0 KB) - added by satya 5 years ago.
7584.patch (6.8 KB) - added by garry.yao 5 years ago.
7584_2.patch (1.4 KB) - added by garry.yao 5 years ago.
7584_3.patch (2.0 KB) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (16)

Changed 5 years ago by satya

comment:1 Changed 5 years ago by garry.yao

  • Cc changed from damo,jamescun,tmonahan to damo, jamescun, tmonahan
  • Component changed from General to UI : Dialogs
  • Status changed from new to confirmed

Changed 5 years ago by garry.yao

comment:2 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review
  • Type changed from Bug to New Feature

I didn't figure out any appropriate design (context-based) of reusing the same menu item for editing both list and items, so a small submenu is introduced, which consist of both the options.

comment:3 Changed 5 years ago by fredck

  • Status changed from review to review_failed
  • Type changed from New Feature to Bug
  • The "List Item Properties" dialog, even if useful, goes out of the scope of this ticket. I think we have another ticket for it and it should be handled there (or in a new ticket). Additionally, it doesn't represent a fix for the problem.
  • In the eyes of the end user, it doesn't matter if the start number has been set in the list or in the list item directly. Because of this, the List Properties dialog must show the start number accordingly. This ticket is in fact limited to this issue.

Changed 5 years ago by garry.yao

comment:4 Changed 5 years ago by garry.yao

  • Status changed from review_failed to review

The "List Item Properties" dialog moves to #7853.

comment:5 Changed 5 years ago by fredck

  • Status changed from review to review_failed

I see that you have now moved the start number attribute from the list item to the list, which is definitely good.

My only concern is that it may still give a bad user experience if "value" is set on all list items. When the user changes the start value in the dialog, only the first item get changed, while the others remain intact. This happens with the second list in the reported TC.

What about removing the "value" attribute from the list items if they are sequential?

comment:6 Changed 5 years ago by garry.yao

Um...not sure as "value" set on all list items are pretty much a rare case as the property is mainly used to break consequential numbering. In any case, here we're talking about the "start" number of the entire list which should not get affiliated with per list item numbering.

comment:7 Changed 5 years ago by fredck

The rare case that makes it weird, justifying this simple fix.

The idea is quite simple... if the users sees: 5, 6, 7, etc.... if the start number changes to 10, we'll have: 10, 11, 12, etc., which sounds quite natural.

Basically, we're talking about changing *sequential* values only.

We're talking about the behavior of the "start" field in the dialog, so all this is definitely related, considering that the change on the field will change all values.

Changed 5 years ago by garry.yao

comment:8 Changed 5 years ago by garry.yao

  • Status changed from review_failed to review

comment:9 Changed 5 years ago by garry.yao

Ticket test added with [6969].

comment:10 Changed 5 years ago by fredck

  • Milestone set to CKEditor 3.6.1
  • Status changed from review to review_passed

comment:11 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6976].

comment:12 Changed 3 years ago by fredck

  • Component changed from UI : Dialogs to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy