Opened 6 years ago

Closed 6 years ago

#7594 closed Bug (fixed)

keyboard navigation of Tool bar broken when we create and destroy Editor instances

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6
Component: Accessibility Version:
Keywords: IBM Cc: damo, jamescun, tmonahan

Description

To reproduce the defect:

  1. Open Ajax sample & create Editor instance by clicking on Create Editor button.
  1. Go in to Editor body, press Alt + F10 to go to tool bar & use left & right Arrow keys to navigate through buttons in the tool bar.
  1. It works fine.
  1. Remove the Editor by clicking on Remove Editor button.
  1. Create a new Editor instance by clicking on Create Editor button.
  1. Go in to Editor body, press Alt + F10 to go to tool bar.
  1. Press Right Arrow key.

Expected Result:

Focus goes to next tool bar button.

Actual Result:

Focus goes in to editor body and cursor is visible in editor body.

Attachments (1)

7645.patch (3.7 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by garry.yao

comment:1 Changed 6 years ago by garry.yao

  • Cc changed from damo,jamescun,tmonahan to damo, jamescun, tmonahan
  • Owner set to garry.yao
  • Status changed from new to review

comment:2 Changed 6 years ago by fredck

#7684 seems to be related to this.

comment:3 Changed 6 years ago by fredck

  • Milestone set to CKEditor 3.6
  • Status changed from review to review_passed

comment:4 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6850].

comment:5 Changed 6 years ago by krst

Still occurs under IE6/7

comment:6 Changed 6 years ago by krst

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 6 years ago by Saare

  • Status changed from reopened to pending

WFM, can you give more details?

comment:8 Changed 6 years ago by garry.yao

WFM

comment:9 Changed 6 years ago by krst

  • Resolution set to fixed
  • Status changed from pending to closed

WFM Sorry for false alarm. with cache disabled, it works fine

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy