Ticket #7606 (closed Bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Editor remains grayed (frozen) after closing a dialog

Reported by: eudoweb Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.5.3
Keywords: Cc:

Description

Hello,

I'm experiencing a strange bug with all versions of CKEditor above 3.5 (3.5.1, 3.5.2 and 3.5.3) while 3.5 was working fine.

When I use a plugin opening a dialog div window (eg. Image upload, Link, Table...) and close this dialog window (either using a button or the X icon), the editor remains in a frozen/grayed state.

This happens on all web browsers I could check it with (Firefox 3.x/4, IE 6 to 9).

I'm quite annoyed by this, as I can't reproduce it on your online demo or using the sample files provided with CKEditor... so it has something to do with our application/environment... I removed all extra plugins, skins, and custom config keys I'm using, with no luck.

But it has something to do with some dialog-oriented code you changed between 3.5 and 3.5.1, as this problem didn't occur with 3.5, even when fully integrated into our application (with extra plugins, skins and some overriden config).

Do you have any clue on this? I looked into the dialog plugin code, and saw that you changed some code related to the "cover" div applied while opening a dialog, but I don't know if it has something to do with that.

Many thanks,

Maxime Abbey, Eudoweb R&D Team

Change History

comment:1 Changed 4 years ago by kkez

eudoweb:

is the editor that stays grayed or it's the whole page?

Could you please see if you can reproduce using the steps in my ticket #7588?

comment:2 Changed 4 years ago by eudoweb

  • Status changed from new to closed
  • Resolution set to duplicate

You're right!

I just realized that I was including ckeditor.js manually, before calling the ckeditor.asp class which already wraps this include (with an ID in the query string).

I removed the extra ckeditor.js include and the problem disappeared. Nice!

To answer your question, the whole page was being grayed out.

@CKEditor Team: I'm setting the ticket status to "duplicate" as it seems to be the same than #7588.

Thanks!

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy