Ticket #7608 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

ckeditor 3.5.3 have problems paste

Reported by: albert700 Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: 3.3.1
Keywords: Cc:

Description

Using ckeditor 3.5.3 in ie8 paste will add "<span style="display:none"> </span>", use the shortcut key ctrl + v paste does not appear

Change History

comment:1 Changed 4 years ago by j.swiderski

  • Version changed from 3.5.3 to 3.3.1
  1. Open replacebycode sample and go to second editor
  2. Select sample text with a mouse and copy it using CRTL+C
  3. Place cursor after dot (with left click), right click to see context menu and paste
    Important: When IE asks whether to allow access, press allow
  4. Paste the same text using CRTL+V

Result: empty div is pasted <span style="display:none"> </span> instead of text (see source view).

This was reproducible in IE8 and IE9 from CKEditor 3.3.2

comment:2 Changed 4 years ago by j.swiderski

  • Status changed from new to pending

It is reproducible in version 3.5.3 but it seems to be fine in latest trunk version. @albert700 can you still reproduce this issue in latest demo version http://nightly.ckeditor.com/demo?

comment:3 Changed 4 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to fixed

Working fine from CKEditor 3.5.4

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy