Ticket #777 (closed Bug: invalid)

Opened 7 years ago

Last modified 7 years ago

Uploading problem

Reported by: jtjohnston@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Pending Expired Cc: fredck

Description

Is this a bug? I used a clean installation, and I get this. I can upload graphics, but not MSWord *.doc

http://sourceforge.net/forum/message.php?msg_id=3928385

Definitely what I see in these two screen shots convinces me there is a bug with a clean installation:

http://www.cegepsherbrooke.qc.ca/~languesmodernes/edahl/Image/1.jpg http://www.cegepsherbrooke.qc.ca/~languesmodernes/edahl/Image/2.JPG

In 1.jpg I should only see image files, and nothing else. Theoretically,in 2.jpg, I should see all files, and certainly sub-folders!? In any case I should be able to create a sub-directory for 2.jpg, but I cannot.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1563620&group_id=75348&atid=543653

Change History

comment:1 Changed 7 years ago by martinkou

  • Reporter changed from martinkou to jtjohnston@…

editor/filemanager/browser/default/connectors/test.html only works for the sub-directories. I have not found a way to upload a file to the main directory (the one under "Image", "File" etc.). Therefore I cannot debug why "Link, Upload, send it to server" will not work on the problem server.


Moved from SF. Original poster: jtjohnston

editor/filemanager/browser/default/connectors/test.html was helpful. I have found a path to a solution.

The php connector has always created the "Image" directory with no problem. On any server. I have always been able to upload images with no problems, no tweaking.

However, one two different Apache servers, I have had to manually create the directories Flash, File and Media before I could get anything to work.

It had something to do with the ownership of the directories. I do not know how I made that break-through. These three directories magically appeared on one server, but I could not upload. When I saw the ownership was "Apache" and not me, I got the idea to delete them and recreate them and reassign chmod 777 before anything would work.

Link, Link Info, Browse server always worked. Image, Image Info, Browse server now work.

Nonetheless, I cannot explain why "Link, Upload, send it to server" and "Image, Upload, send it to server" now work one server, but not on another. The server not working runs in safe-mode is all I can see. This function refused to work on the successful before my last fresh install of FCKeditor and re-tweaking permissions.

Do you do something different when you create Image?

John


Moved from SF. Original poster: jtjohnston

I'm not able to reproduce the problem here. There screenshots are not enough for that.

I would ask you to please test the PHP connector by using the "editor/filemanager/browser/default/connectors/test.html" page. With this page you can see the responses from the connector and find out specific server side errors.

Let us know the results.

Frederico Caldeira Knabben


http://www.fckeditor.net "Support Open Source Software"


Moved from SF. Original poster: fredck

It is a bug. There is no other way to explain it. That's why I'm reporting it here.


Moved from SF. Original poster: jtjohnston

Please use our forums for discussions.


Moved from SF. Original poster: fredck

comment:2 Changed 7 years ago by alfonsoml

  • Keywords Pending added

There's also a test.html file in the filemanager/upload folder. You should try that to understand your problems.

In the nightlies now the connectors and upload folders have been unified so it might be easier to find out any problem (and there's a uploadtest.html file to check just the uploads)

comment:3 Changed 7 years ago by fredck

  • Keywords Expired added
  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy