Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#7804 closed Bug (fixed)

<wbr> tag in source is breaking the editor.

Reported by: satya Owned by: Saare
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.0
Keywords: IBM Cc: damo, jamescun, tmonahan, markuspaek

Description

To reproduce the defect:

  1. Open CK Editor sample, Go to Source and paste the following code.
<p> dublin <wbr> ireland </wbr> </p>
<p> paris france </p>
  1. Go to Rich Text view.

Expected Result: 2 paragraphs that we have set in step 1 should be displayed.

Actual Result:

FF: An extra empty paragraph is added between 2 paragraphs.

Safari,Opera,Chrome: An extra empty paragraph is added at end of 2 paragraph.

  1. Switch between Source mode & Rich text couple of times.

Issue1: IN FF, Safari,Opera,Chrome You will see lot of extraneous and heavily nested <WBR> tags in the content and empty paragraphs gets adding in the content.

  1. Navigate between Source mode & Rich text some 20 times.

Issue2: In FF& Chrome Editor is broken and when i look at firebug it shows an error and the Error is too much recursion [Break On This Error] if(w){for(t=0;t<v&&q[t].pri<s;t++){}fo...t=s.$.scopeName.toLowerCase()+':'+t;

Attachments (1)

7804.patch (1.6 KB) - added by Saare 6 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by damo

The original description needs to be refined. Using </wbr> is not valid as the content model for <wbr> is blank, e.g. just like <br>.

There are still major problems adding simple <wbr> tags to the content. CKEditor creates closing </wbr> tags. Which is the starting point in Satya's test case. As you go between source mode and rich text, CKEditor continues to add additional opening and closing <wbr> tags.

comment:2 Changed 6 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.0

Issue 1 is also reproducible for IE9

The error from Firebug is:
Message: too much recursion
File: /_source/core/dom/document.js
Line: 248
Code: this.$.write( html );

comment:3 Changed 6 years ago by fredck

  • Cc markuspaek added

#5281 has been marked as DUP.

Changed 6 years ago by Saare

comment:4 Changed 6 years ago by Saare

  • Owner set to Saare
  • Status changed from confirmed to review

comment:5 Changed 6 years ago by fredck

  • Status changed from review to review_passed

comment:6 Changed 6 years ago by fredck

  • Milestone set to CKEditor 3.6.1

comment:7 follow-up: Changed 6 years ago by Saare

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6931].

comment:8 in reply to: ↑ 7 Changed 5 years ago by ilovedrupalverymuch

Replying to Saare:

Fixed with [6931].

satya posted two issues and according to the last entry of this ticket, the bug has been fixed already. My question is which issue was fixed? I tried the test case in the demo but still issue no. 1 was not resolved. I will try to check if I can recreate the problem stated in issue no. 2..

comment:9 Changed 5 years ago by wwalc

@ilovedrupalverymuch - in which demo did you try it? Did you check it in the nightly build?

Could you provide more details, what problems do you see and in what browser?

My result in Firefox is:

<p>
	dublin <wbr /> ireland</p>
<p>
	paris france</p>

and it is correct, see the first comment added by damo.

comment:10 follow-up: Changed 5 years ago by ilovedrupalverymuch

Hi wwalc,

I tried the test case by satya in http://ckeditor.com/demo in FF, IE, and Chrome yesterday. As soon as I inserted the test case and press the source button around 50 times, the demo crashed.

What is strange is when I tried the same test case this morning, the problem was gone.

My question is, if I will replace the dtd.js file from Fixed with [6931] in our server, will it solve the problem? Will I have the same result as the demo "now" (because I was certain it was having a problem yesterday)?

If I am missing something, please shed some light for I am currently unable to make it work in our server.

Thanks anyways for a prompt response to my post.

Cheers

Last edited 5 years ago by ilovedrupalverymuch (previous) (diff)

comment:11 in reply to: ↑ 10 Changed 5 years ago by ilovedrupalverymuch

Replying to ilovedrupalverymuch:

Hi wwalc,

I tried the test case by satya in http://ckeditor.com/demo in FF, IE, and Chrome yesterday. As soon as I inserted the test case and press the source button around 50 times, the demo crashed.

What is strange is when I tried the same test case this morning, the problem was gone.

My question is, if I will replace the dtd.js file from Fixed with [6931] in our server, will it solve the problem? Will I have the same result as the demo "now" (because I was certain it was having a problem yesterday)?

If I am missing something, please shed some light for I am currently unable to make it work in our server.

Thanks anyways for a prompt response to my post.

Cheers

Hi wwalc,

Just an update on my previous post. I had the CKEditor working on our site but it seems like the "dtd.js" patch wouldn't work by simply replacing the file from an older version of CKEditor. I had to update the entire CKEditor with the latest build to make it work.

This is just an FYI.

Cheers,

Davis

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy