Ticket #7839 (closed Bug: fixed)

Opened 4 years ago

Last modified 11 months ago

Pasting multi level Numbered list from word not working properly

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: Plugin : Paste from Word Version: 3.5.3
Keywords: IBM Cc: damo, tmonahan

Description

To reproduce the defect:

Open CK Editor,copy the list from attached doc and paste in to editor.

Expected Result: Multilevel Numbered list in the document should paste properly.

Actual Result: Nesting between the outer and inner lists is removed and also the ordering of list items is not maintained. when we try to insert new list items it is not updating the order of other list items at the same level.

Attachments

Multi level Numbered list.doc (21.5 KB) - added by satya 4 years ago.
7839.patch (5.5 KB) - added by garry.yao 4 years ago.
7839_2.patch (5.7 KB) - added by garry.yao 4 years ago.

Change History

Changed 4 years ago by satya

comment:2 in reply to: ↑ 1 Changed 4 years ago by satya

Replying to j.swiderski:

This is reproducible for all versions of IE.

  1. Open sample file and copy the whole list
  2. You don't have to care about word formatting options in config.js (leave them to true)
  1. If you paste the list using CRTL+V the result is as described above.
  2. If you use "paste from word" dialog and allow for access (when IE message pops out) this will work in IE6 and IE7 but for IE8 and IE9 list will be broken.
  3. If you use "paste from word" dialog and disallow for access (when IE message pops out) this will work for all IE versions. List will be pasted correctly

In my opinion lists from word should be pasted with "paste from word" button. The only thing that you might not like is the point b. But this is probably due to how older and newer versions of IE see it. If any one else thinks this is not a bug please close it.

This has occurred in version 3.5.3 rev [6616] which is a progress in pasting lists comparing to [6615].

The only major problem with IE6&7 and [6616] is that those browsers can break down when modifying list pasted from word. I have created new ticket for this. Please refer to #7843

@ j.swiderski even when i use the option b lists in level 1 & level 2 getting combined as single list. i think we should not close this defect, since this was a regression and it was working in earlier versions.

comment:3 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.5.3

I have deleted my first comment as I brought to much confusion. I have got a little mixed up with this issue. Here is the new comment:

This is reproducible for all versions of IE.

  1. Open sample file and copy the whole list
  2. You don't have to care about word formatting options in config.js (leave them to true)

Before revision [6585], CRTL+V, paste from word “allow” and “disallow” produced the same correct result. Since that revision lists pasted from word were flatten (from mulit-level to one level)

In [6616] there was a slight improvement:

  1. If you paste the list using CRTL+V the result is as described by @satya.
  2. If you use "paste from word" dialog and allow for access (when IE message pops out) this will work in IE6 and IE7 but for IE8 and IE9 list will be broken.
  3. If you use "paste from word" dialog and disallow for access (when IE message pops out) this will work for all IE versions. List will be pasted correctly.

The only major problem with IE6&7 and [6616] is that those browsers can break down when modifying list pasted from word. I have created new ticket for this. Please refer to #7843

To sum up – this worked correctly in IE till [6585] (exclusive).

Having said all that, I also think that bug #7843 is the result of [6585].

Changed 4 years ago by garry.yao

comment:4 Changed 4 years ago by garry.yao

  • Status changed from confirmed to review
  • Owner set to garry.yao
  • Component changed from General to Core : Pasting

comment:5 follow-up: ↓ 6 Changed 4 years ago by fredck

  • Status changed from review to review_failed

After patch, I can confirm that the list is properly pasted with Firefox and IE9 in IE9 Mode.

With IE9 in Compatibility Mode instead, I'm having the "It was not possible to clean up the pasted data duo to an internal error" error.

Changed 4 years ago by garry.yao

comment:6 in reply to: ↑ 5 Changed 4 years ago by garry.yao

  • Status changed from review_failed to review

Replying to fredck:

With IE9 in Compatibility Mode instead, I'm having the "It was not possible to clean up the pasted data duo to an internal error" error.

Looked for a Array::indexOf again in IE7 ;(

comment:7 Changed 4 years ago by fredck

  • Status changed from review to review_passed

The new patch is ok, but the debug changes from line 1321 are also included on it. This is a serious problem, so please be sure to revert it when committing.

comment:8 Changed 4 years ago by fredck

  • Milestone set to CKEditor 3.6.1

comment:9 Changed 4 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6977].

comment:10 Changed 11 months ago by fredck

  • Component changed from Core : Pasting to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy