Ticket #785 (closed Bug: fixed)

Opened 7 years ago

Last modified 7 years ago

Applying a style to multiple table cells corrupts the table

Reported by: snies@… Owned by:
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version:
Keywords: SF Cc:

Description (last modified by martinkou) (diff)

When editing a large table a common use case is for the user to select multiple rows and/or cells and then apply formatting. Applying a font or changing the font size works as expected - the change is applied to the contents of each selected cell individually.

However, applying a style to multiple cells does NOT work as expected. For example, I created a 3x2 table and populated it with test data. I then selected the lower 4x4 grid and applied a style. The problem is that a single <span> tag is generated to span multiple <td> tags. The end result is that the table structure is corrupted.

Following is the resulting HTML from this scenario:

<table width="200" cellspacing="1" cellpadding="1"
border="1" align="" summary="">
<tbody>
<tr>
<td>Steve</td>
<td>Nies</td>
</tr>
<tr>
<span class="normal">
<td>Sheri</td>
<td>Nies</td>
<td>Jenny</td>
<td>Nies</td>
</span>
</tr>
<tr>
</tr>
</tbody>
</table>

Notice that the single <span> tag encompasses multiple <td> tags (i.e., the cells that were selected by the user).


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1579269&group_id=75348&atid=543653

Change History

comment:1 Changed 7 years ago by martinkou

  • Description modified (diff)
  • Reporter changed from martinkou to snies@…

oops - in the example I meant to say that I selected the lower 2x2 cells (a total a four cells).


Moved from SF. Original poster: snies

comment:2 Changed 7 years ago by fredck

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to FCKeditor 2.5

This one works well now for IE. With FF, we have a different behavior, described at #1345.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy