Ticket #7854 (closed Bug: fixed)

Opened 3 years ago

Last modified 10 months ago

IE 6&7 Getting handlers when we navigate to first paragraph(non-editable) in editor body.

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.2
Keywords: IBM Cc: damo, jamescun, tmonahan

Description

To reproduce the defect:

  1. Open CK Editor and create some paragraphs of text(both editable and non editable) & make first paragraph non-editable or copy the below code and paste it is source view.
<p contenteditable="false">
	first non editable paragraph.</p>
<p> first editable paragraph. </p>
<p contenteditable="false">
	second non editable paragraph.</p>
<p> second editable paragraph. </p>
  1. Go back to Rich text keep the cursor at end of last paragrAph and navigate to top paragraph using arrow keys.

Issue: we are getting handlers when we go to the Top Paragraph(non-editable) and we can't come out of it.

Only happening in IE6 & 7

I have attached a screenshot of the error.

Attachments

handlers for 1st paragraph.jpg (43.6 KB) - added by satya 3 years ago.

Change History

Changed 3 years ago by satya

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 3.3.2

This has occurred first in version 3.2.1 and then from version 3.3.2 till current.

In versions 3.2.2 - 3.3.1 navigating with arrows caused insertion of empty paragraph at the top.

In versions 3.0.2 - 3.2 the first non-editable paragraph was deleted when navigating with arrows.

comment:2 Changed 10 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to fixed

I cannot reproduce it on IE8 on CKeditor 4.3.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy