Ticket #7871 (closed Bug: invalid)

Opened 3 years ago

Last modified 8 months ago

Error thrown when we try to paste the date from Word.

Reported by: satya Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.6.1
Keywords: IBM Cc: damo, jamescun, tmonahan

Description

To reproduce the defect:

with config.pasteFromWordRemoveStyle & config.pasteFromWordRemoveFontStyles set to false copy an empty table or a simple list from any word doc and paste in to editor using Ctrl + V or Paste from Word dialog.

Expected Result Copied data from word doc should paste properly in to editor body.

Actual Result: we are getting error dialog saying It was not possible to clean up the pasted data due to an internal error

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by j.swiderski

  • Status changed from new to pending

I could not reproduce the issue neither on trunk nor on branch. Everything seems to be fine.

The only problem I have noticed is that two-level list pasted from word gets flattened or split but I have reported this in a different ticket #7872

comment:2 in reply to: ↑ 1 Changed 3 years ago by satya

Replying to j.swiderski:

I could not reproduce the issue neither on trunk nor on branch. Everything seems to be fine.

The only problem I have noticed is that two-level list pasted from word gets flattened or split but I have reported this in a different ticket #7872

@ j.swiderski have u applied the config parametres that i mentioned in the the steps to reproduce

comment:3 follow-up: ↓ 4 Changed 3 years ago by j.swiderski

Yes I have.

config.pasteFromWordRemoveFontStyles=false;
config.pasteFromWordRemoveStyles=false;

I have checked this on XP and win 7 and Ubuntu in latest stable version, latest trunk and on branch. I have used the list and table pasted from word 2003 (not 2007 - maybe it matters)

You think you could provide me with information on OS and Browser you are using and perhaps a word file causing the problem?

comment:4 in reply to: ↑ 3 Changed 3 years ago by satya

Replying to j.swiderski:

Yes I have.

config.pasteFromWordRemoveFontStyles=false;
config.pasteFromWordRemoveStyles=false;

I have checked this on XP and win 7 and Ubuntu in latest stable version, latest trunk and on branch. I have used the list and table pasted from word 2003 (not 2007 - maybe it matters)

we debugged it and found that it's an issue in our build. pls close this ticket

You think you could provide me with information on OS and Browser you are using and perhaps a word file causing the problem?

comment:5 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to invalid

comment:6 Changed 8 months ago by fredck

  • Component changed from General to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy