Opened 4 years ago

Last modified 3 years ago

#7888 confirmed Bug

Deleting the link in editor - the text font stays underlined

Reported by: vky Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.1
Keywords: Firefox Cc:


  1. Create a link (i.e. to an anchor)
  2. Save and re-open the page for editing
  3. Move cursor to last position of link
  4. Select the whole link and remove it
  5. Start typing plain text

PROBLEM: the text is undelined, but should have no format

Change History (7)

comment:1 Changed 4 years ago by j.swiderski

  • Keywords delete link font underline removed

comment:2 Changed 4 years ago by j.swiderski

  • Status changed from new to pending

I had difficulties reproducing the issue. Could you tell me on what browser and OS does it occur?

Also is it reproducible in clean demo version or are you using CKEditor with other software and problem occurs only there?

Waiting for your comments.

comment:3 Changed 4 years ago by vky


It's FF3.6.17. I'm easily reproducing it at the demo on the site.

Just write some text, select it, define a link, choose the whole line (from the end to the beginning), hit the backspace than start writing


comment:4 Changed 4 years ago by j.swiderski

  • Keywords Firefox added
  • Status changed from pending to confirmed
  • Version changed from 3.6 to 3.5.1

True for FF browsers from CKEditor 3.5.1. Before 3.5.1 version, scenario from comment 3 caused that text was still written in (suppose to be deleted) link.

comment:5 Changed 4 years ago by vky

It happens in FF3.6.17.....

comment:6 Changed 4 years ago by j.swiderski

Actually it happens on both FF3.6 and FF4

comment:7 Changed 3 years ago by j.swiderski

This is no longer reproducible in latest Firefox 15 but it is still reproducible in Firefox 3.6.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy